summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnty02019-07-22 16:26:44 +0200
committerAnty02019-07-22 16:26:44 +0200
commit661c49e557233b5ec52663286caeb3dad66eb068 (patch)
treee16c17ecdc886a85b9e7eeb6ca649b2af9f6baa9
downloadaur-661c49e557233b5ec52663286caeb3dad66eb068.tar.gz
initial commit;
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f777ec21a357
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-urwid_readline
+ pkgdesc = Text input widget for urwid that supports readline shortcuts
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://github.com/rr-/urwid_readline
+ arch = x86_64
+ license = mit
+ makedepends = cython
+ makedepends = python-setuptools
+ depends = python
+ depends = python-urwid
+ source = https://github.com/rr-/urwid_readline/archive/0.9.tar.gz
+ sha256sums = 3e78ffdcf9cc68965df4e9ce07f630cd2ea8c510739d37cb8503059bf5527855
+
+pkgname = python-urwid_readline
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3219985a6e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Anty0 <anty150 at gmail dot com>
+
+pkgname='python-urwid_readline'
+_pkgname='urwid_readline'
+pkgver='0.9'
+pkgrel=1
+pkgdesc="Text input widget for urwid that supports readline shortcuts"
+url="https://github.com/rr-/urwid_readline"
+depends=('python'
+ 'python-urwid')
+makedepends=('cython' 'python-setuptools')
+license=('mit')
+arch=('x86_64')
+source=("https://github.com/rr-/urwid_readline/archive/${pkgver}.tar.gz")
+sha256sums=('3e78ffdcf9cc68965df4e9ce07f630cd2ea8c510739d37cb8503059bf5527855')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/"
+ python setup.py build_ext --inplace
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/"
+ python setup.py install --root="${pkgdir}"
+ install -D -m644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+}