summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2019-01-07 01:10:44 +0800
committerKaizhao Zhang2019-01-07 01:10:44 +0800
commit7b559f6982c49f4f070e7572c031a8dcd68f3baa (patch)
treea76f370e0ccc8665fd6ab21434aba6e44d0f36eb
downloadaur-7b559f6982c49f4f070e7572c031a8dcd68f3baa.tar.gz
Initial import with version 1.1.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD41
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed3bddb357da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-userpath
+ pkgdesc = Cross-platform tool for adding locations to the user PATH, no sudo/runas required!
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/ofek/userpath
+ arch = any
+ license = MIT
+ license = APACHE
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python-click
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/24/7b/3b991e87d08211a95bafcadc370cb17e75a7dfb51e6f9ce9247f8cfff4c0/userpath-1.1.0.tar.gz
+ sha256sums = c4aa4b20298d14272e2a39047a38a7e2195c1d697dd37dec247e2331067e7f31
+
+pkgname = python-userpath
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..924dfb95c209
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2750ea13184
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+
+_srcname=userpath
+
+pkgname=python-userpath
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Cross-platform tool for adding locations to the user PATH, no sudo/runas required!"
+arch=('any')
+url="https://github.com/ofek/userpath"
+license=('MIT' 'APACHE')
+depends=(
+ 'python-click'
+)
+makedepends=('python' 'python-setuptools')
+options=(!emptydirs)
+source=(
+ "https://files.pythonhosted.org/packages/24/7b/3b991e87d08211a95bafcadc370cb17e75a7dfb51e6f9ce9247f8cfff4c0/userpath-${pkgver}.tar.gz"
+)
+sha256sums=(
+ 'c4aa4b20298d14272e2a39047a38a7e2195c1d697dd37dec247e2331067e7f31'
+)
+
+prepare() {
+ cd "${srcdir}/${_srcname}-${pkgver}"
+ # no need to include tests files
+ rm tests/__init__.py
+}
+
+build() {
+ cd "${srcdir}/${_srcname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_srcname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ install -Dm644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+ install -Dm644 LICENSE-MIT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
+ install -Dm644 LICENSE-APACHE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-APACHE"
+}