summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-12-20 19:11:31 -0700
committerMark Wagie2020-12-20 19:11:31 -0700
commit2dfe158d7d913e5adf20d9ca0d78dcc8a7128c83 (patch)
tree41ac6f524537707642a10c3b779eb999d9f0ca49
parent9863bf97fd56b015e725a6cea63f326c6bd83d88 (diff)
downloadaur-2dfe158d7d913e5adf20d9ca0d78dcc8a7128c83.tar.gz
disable hash randomization
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD3
3 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96b858847c3d..6dd58df707af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-userspacefs
pkgdesc = Cross-platform user-space file systems for Python
pkgver = 1.0.13
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/rianhunter/userspacefs
arch = any
license = GPL3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index edd702d991f2..ab5b35b0beac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-userspacefs
_name=${pkgname#python-}
pkgver=1.0.13
-pkgrel=4
+pkgrel=5
pkgdesc="Cross-platform user-space file systems for Python"
arch=('any')
url="https://github.com/rianhunter/userspacefs"
@@ -21,5 +21,6 @@ build() {
package() {
cd "$_name-$pkgver"
+ export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}