summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKartik Mohta2020-05-31 11:22:22 -0700
committerKartik Mohta2020-05-31 11:22:22 -0700
commit824523521b5b9180bd16d89e20f8ad8b41014485 (patch)
tree392ad5674874d7f504ee39de854d5aafeaf7b0c5
parent8ac850e737575c079de39456256e2cdc85d00124 (diff)
downloadaur-824523521b5b9180bd16d89e20f8ad8b41014485.tar.gz
Switch source to github repo
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aad7a4cb6eb8..d5b2e75537d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-vcstool
- pkgdesc = vcstool provides a command line tool to invoke vcs commands on multiple repositories.
+ pkgdesc = A version control system tool designed to make working with multiple repositories easier
pkgver = 0.2.9
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dirk-thomas/vcstool
arch = any
license = Apache
@@ -9,8 +9,8 @@ pkgbase = python-vcstool
depends = python
depends = python-yaml
conflicts = python2-vcstool
- source = https://files.pythonhosted.org/packages/source/v/vcstool/vcstool-0.2.9.tar.gz
- sha256sums = 4add62ef4908fadbff192219f88e0f159c637d3650097022d7e6480d449060d1
+ source = https://github.com/dirk-thomas/vcstool/archive/0.2.9.tar.gz
+ sha256sums = 96f2d5d3953b012b434a803c1a9b849511aaf7eaa227994225ded209c4b23927
pkgname = python-vcstool
diff --git a/PKGBUILD b/PKGBUILD
index 862ffb9345c7..4aba65126aa0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
-pkgbase='python-vcstool'
pkgname=('python-vcstool')
-_module='vcstool'
pkgver='0.2.9'
-pkgrel=1
-pkgdesc="vcstool provides a command line tool to invoke vcs commands on multiple repositories."
-url="https://github.com/dirk-thomas/vcstool"
+pkgrel=2
+pkgdesc='A version control system tool designed to make working with multiple repositories easier'
+arch=('any')
+url='https://github.com/dirk-thomas/vcstool'
+license=('Apache')
depends=('python' 'python-yaml')
-conflicts=('python2-vcstool')
makedepends=('python-setuptools')
-license=('Apache')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('4add62ef4908fadbff192219f88e0f159c637d3650097022d7e6480d449060d1')
+
+conflicts=('python2-vcstool')
+source=("https://github.com/dirk-thomas/vcstool/archive/${pkgver}.tar.gz")
+sha256sums=('96f2d5d3953b012b434a803c1a9b849511aaf7eaa227994225ded209c4b23927')
+
+_module='vcstool'
build() {
cd "${srcdir}/${_module}-${pkgver}"