summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Kuntze2021-09-09 13:25:43 +0200
committerNoel Kuntze2021-09-09 13:25:43 +0200
commita03a558357bda4362a3bb9c6de68837102a41b9c (patch)
treeafb8831721ca8519def268bc0098b07dcd6fc2ad
parent9ca0609551a5c2d6831de6b4875a38066eb3e5de (diff)
downloadaur-a03a558357bda4362a3bb9c6de68837102a41b9c.tar.gz
Bump to 5.9.3, use strongSwan source instead
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
-rw-r--r--use-sitepackages.patch9
3 files changed, 45 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63278c75d5db..a701f09eacf6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = python-vici
pkgdesc = vici python egg to talk to strongSwan via VICI socket
- pkgver = 5.8.0
- pkgrel = 2
+ pkgver = 5.9.3
+ pkgrel = 1
url = https://strongswan.org
arch = any
- license = GPL2
+ license = MIT
+ makedepends = automake
+ makedepends = autoconf
makedepends = python-setuptools
depends = python
- source = https://files.pythonhosted.org/packages/f7/5b/59a1b82929255dca851bbef8ff368ea465d5adfa7c6a8b50824bcf6c2f6e/vici-5.8.0.tar.gz
- sha256sums = de0b9029e5c4ab16f293567dd56b59de2ad1984dd18a3980c787573aeb44b88a
+ source = https://github.com/strongswan/strongswan/releases/download/5.9.3/strongswan-5.9.3.tar.bz2
+ source = use-sitepackages.patch
+ sha256sums = 9325ab56a0a4e97e379401e1d942ce3e0d8b6372291350ab2caae0755862c6f7
+ sha256sums = 658817b0d3c1fd221521176c188b0b499c91f28c6a50a3cdbb3efd181868b960
pkgname = python-vici
-
diff --git a/PKGBUILD b/PKGBUILD
index cc1fb8bc980a..ba3a92c5ef6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,38 @@
pkgname=python-vici
-_pypi_pkgname=vici
-pkgver=5.8.0
-pkgrel=2
+pkgver=5.9.3
+pkgrel=1
pkgdesc="vici python egg to talk to strongSwan via VICI socket"
arch=(any)
url="https://strongswan.org"
-license=('GPL2')
-makedepends=('python-setuptools')
+license=('MIT')
+makedepends=('automake' 'autoconf' 'python-setuptools')
depends=('python')
-source=("https://files.pythonhosted.org/packages/f7/5b/59a1b82929255dca851bbef8ff368ea465d5adfa7c6a8b50824bcf6c2f6e/vici-5.8.0.tar.gz")
-sha256sums=('de0b9029e5c4ab16f293567dd56b59de2ad1984dd18a3980c787573aeb44b88a')
+source=("https://github.com/strongswan/strongswan/releases/download/$pkgver/strongswan-$pkgver.tar.bz2"
+ "use-sitepackages.patch"
+ )
+
+sha256sums=('9325ab56a0a4e97e379401e1d942ce3e0d8b6372291350ab2caae0755862c6f7'
+ '658817b0d3c1fd221521176c188b0b499c91f28c6a50a3cdbb3efd181868b960')
build() {
- cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
- python setup.py build || return 1
+ cd "$srcdir/strongswan-$pkgver"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --disable-defaults \
+ --enable-python-eggs
+
+ cd src/libcharon/plugins/vici/python
+ make all
+ python3 setup.py build
+}
+
+check() {
+ cd "$srcdir/strongswan-$pkgver"
+ make -C src/libcharon/plugins/vici/python check
}
package() {
- cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
- python setup.py install --root=${pkgdir} --optimize=1 || return 1
+ cd "$srcdir/strongswan-$pkgver/src/libcharon/plugins/vici/python/"
+ python3 setup.py install --root="$pkgdir" --optimize=1
}
diff --git a/use-sitepackages.patch b/use-sitepackages.patch
new file mode 100644
index 000000000000..9e029a5322a0
--- /dev/null
+++ b/use-sitepackages.patch
@@ -0,0 +1,9 @@
+diff --git a/src/libcharon/plugins/vici/python/tox.sh b/src/libcharon/plugins/vici/python/tox.sh
+index 1a4f786..d52b626 100755
+--- a/src/libcharon/plugins/vici/python/tox.sh
++++ b/src/libcharon/plugins/vici/python/tox.sh
+@@ -1,3 +1,3 @@
+ #!/bin/sh
+
+-${TOX} -c ${srcdir} --skip-missing-interpreters
++${TOX} -c ${srcdir} --skip-missing-interpreters --sitepackages