summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Bourgeois2016-11-30 02:01:44 +0100
committerQuentin Bourgeois2016-12-02 01:15:07 +0100
commitd0fae3320aac008b889e160661d3a5a075908381 (patch)
treead16ca58b48333ef75198dde44610fd51db22486
parentaac5f95f26f3e8d83fd814b00a8ede9b13a17d69 (diff)
downloadaur-d0fae3320aac008b889e160661d3a5a075908381.tar.gz
<PKGBUILD/style: Change how bash variables are referenced>
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dac136428a07..c13ad0ef3c8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Quentin Bourgeois <quentin+archlinux@bourgeois.eu>
pkgbase=viivakoodi
-pkgname=("python2-$pkgbase" "python-$pkgbase")
+pkgname=("python2-${pkgbase}" "python-${pkgbase}")
pkgver=0.8.0
pkgrel=1
pkgdesc='Barcode generator for Python. Fork of pyBarcode project.'
arch=('any')
-url="https://github.com/kxepal/$pkgbase"
+url="https://github.com/kxepal/${pkgbase}"
license=('MIT')
-source=("$pkgbase-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+source=("${pkgbase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
sha256sums=('e1a17dc24975d5242202cfbb7534d69dd14eeb26bdf8a10f056c7b04904fef1e')
makedepends=('python-setuptools'
'python2-setuptools')
check() {
- cd "$srcdir/$pkgbase-$pkgver"
+ cd "${srcdir}/${pkgbase}-${pkgver}"
for py_int in python3 python2; do
- msg "Testing $pkgbase-$pkgver with $py_int"
- "$py_int" ./test.py
+ msg "Testing ${pkgbase}-${pkgver} with ${py_int}"
+ "${py_int}" ./test.py
done
}
@@ -28,11 +28,11 @@ package_python-viivakoodi() {
checkdepends=('python-pytest'
'python-mock'
'python-tox')
- cd "$srcdir/$pkgbase-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE.launcher"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.launcher"
}
package_python2-viivakoodi() {
@@ -42,9 +42,9 @@ package_python2-viivakoodi() {
'python2-mock'
'python2-tox')
- cd "$srcdir/$pkgbase-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE.launcher"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.launcher"
}