summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrett Cornwall2024-05-25 09:50:43 -0700
committerBrett Cornwall2024-05-25 09:50:43 -0700
commit1fa68e6f2088248684e72f853334a0eed7d5e2cf (patch)
tree3f42b65c43a9dd2934ddd36909ad7168dd5b3322
parent219fdbb38835386fbacbd442d95718c40210016e (diff)
downloadaur-1fa68e6f2088248684e72f853334a0eed7d5e2cf.tar.gz
Remove unused check_token.patch, license to spdx
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--check_token.patch41
3 files changed, 4 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5050705e37c..84989566805e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-vipaccess
pkgdesc = A free software implementation of Symantec's VIP Access application and protocol
pkgver = 0.14.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dlenski/python-vipaccess
arch = any
- license = Apache
+ license = Apache-2.0
checkdepends = python-nose2
makedepends = python-setuptools
depends = python-pycryptodome
diff --git a/PKGBUILD b/PKGBUILD
index b1684d66cfde..fbc873cd11e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgname=python-vipaccess
pkgver=0.14.2
-pkgrel=1
+pkgrel=2
pkgdesc="A free software implementation of Symantec's VIP Access application and protocol"
arch=('any')
url="https://github.com/dlenski/python-vipaccess"
-license=('Apache')
+license=('Apache-2.0')
makedepends=('python-setuptools')
checkdepends=('python-nose2')
depends=('python-pycryptodome' 'python-lxml' 'python-oath' 'python-requests')
diff --git a/check_token.patch b/check_token.patch
deleted file mode 100644
index afdbe0d92076..000000000000
--- a/check_token.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 34b6ce697429892141ad511d5e8e4b95e40abb98 Mon Sep 17 00:00:00 2001
-From: zecoj <zecoj@users.noreply.github.com>
-Date: Wed, 8 Mar 2017 11:24:10 +1100
-Subject: [PATCH] Update check_token to reflect url change
-
----
- vipaccess/utils.py | 18 ++++++++++++------
- 1 file changed, 12 insertions(+), 6 deletions(-)
-
-diff --git a/vipaccess/utils.py b/vipaccess/utils.py
-index f91b615..4ced9c9 100644
---- a/vipaccess/utils.py
-+++ b/vipaccess/utils.py
-@@ -254,15 +254,21 @@ def generate_qr_code(uri):
- def check_token(token_id, secret):
- '''Check the validity of the generated token.'''
- otp = totp(binascii.b2a_hex(secret).decode('utf-8'))
-- test_url = 'https://idprotect.vip.symantec.com/testtoken.v'
-+ test_url = 'https://vip.symantec.com/otpCheck'
- token_check = requests.post(
- test_url,
-- data=dict(
-- tokenID=token_id,
-- firstOTP=otp
-- )
-+ data={
-+ 'cr1':otp[0],
-+ 'cr2':otp[1],
-+ 'cr3':otp[2],
-+ 'cr4':otp[3],
-+ 'cr5':otp[4],
-+ 'cr6':otp[5],
-+ 'cred':token_id,
-+ 'continue':'otp_check'
-+ }
- )
-- if "Your credential is functioning properly and is ready for use" in token_check.text:
-+ if "Your VIP Credential is working correctly" in token_check.text:
- return True
- else:
- return False