summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Rebischke2016-11-06 22:26:45 +0100
committerChristian Rebischke2016-11-06 22:26:45 +0100
commit71dea34e72322c70a3ec47bd9e1b32c44fb951e0 (patch)
tree70211a179bb5cffd3009e6af4194392110077175
parentdba0cbcc1fae279ce13aea4d373d310faa2a9724 (diff)
downloadaur-71dea34e72322c70a3ec47bd9e1b32c44fb951e0.tar.gz
initial release of split package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 35 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b4bafd9bb79..381de8dceab8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
# Generated by mksrcinfo v8
-# Thu Jan 28 22:43:56 UTC 2016
+# Sun Nov 6 21:26:16 UTC 2016
pkgbase = python-virustotal-api
pkgdesc = Virus Total Public/Private/Intel API
- pkgver = 1.0.9
+ pkgver = 1.1.2
pkgrel = 1
- url = https://pypi.python.org/pypi/virustotal-api#downloads
+ url = https://github.com/erocarrera/virustotal-api
arch = any
license = MIT
makedepends = python
makedepends = python2
- source = https://pypi.python.org/packages/source/v/virustotal-api/virustotal-api-1.0.9.tar.gz
- sha512sums = c4536f1cf656c4aa868025e3043ea7095ce8e0d09275a5769a8be1746fbdf0f1888fde0a6c9fdd1448eb34545cf528f1ba54b065a6afaa6ec716ec63d165782b
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://pypi.python.org/packages/source/v/virustotal-api/virustotal-api-1.1.2.tar.gz
+ sha512sums = ed687b1b75532d23489bc9a9dffc99e60ee041fd3e87740e5738c0c274af31fad92e8de06560961f15e3a617cb896d0a2749c4f125ff5257c19e01595f1f3d0e
pkgname = python-virustotal-api
depends = python
+ depends = python-future
pkgname = python2-virustotal-api
depends = python2
+ depends = python2-future
diff --git a/PKGBUILD b/PKGBUILD
index 7c93d51ed836..c60234d95b2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,41 @@
-# Maintainer: Christian Rebischke <Chris.Rebischke@archlinux.org>
+# Maintainer: Christian Rebischke <chris.rebischke[at]archlinux[dot]org>
pkgbase=python-virustotal-api
_pyname=virustotal-api
pkgname=('python-virustotal-api' 'python2-virustotal-api')
-makedepends=('python' 'python2')
-pkgver=1.0.9
+pkgver=1.1.2
pkgrel=1
pkgdesc="Virus Total Public/Private/Intel API"
arch=('any')
-url="https://pypi.python.org/pypi/virustotal-api#downloads"
+url="https://github.com/erocarrera/virustotal-api"
license=('MIT')
-source=("https://pypi.python.org/packages/source/v/$_pyname/$_pyname-$pkgver.tar.gz")
-sha512sums=('c4536f1cf656c4aa868025e3043ea7095ce8e0d09275a5769a8be1746fbdf0f1888fde0a6c9fdd1448eb34545cf528f1ba54b065a6afaa6ec716ec63d165782b')
+makedepends=('python' 'python2' 'python-setuptools' 'python2-setuptools')
+source=("https://pypi.python.org/packages/source/v/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+sha512sums=('ed687b1b75532d23489bc9a9dffc99e60ee041fd3e87740e5738c0c274af31fad92e8de06560961f15e3a617cb896d0a2749c4f125ff5257c19e01595f1f3d0e')
+
+prepare() {
+ cd ${srcdir}
+ cp -r virustotal-api-${pkgver} virustotal-api2-${pkgver}
+}
+
+check() {
+ cd ${srcdir}/virustotal-api-${pkgver}
+ python setup.py check
+
+ cd ${srcdir}/virustotal-api2-${pkgver}
+ python2 setup.py check
+}
package_python-virustotal-api() {
- depends=('python')
- cd "$srcdir/$_pyname-$pkgver"
- python setup.py install -O1 --root=$pkgdir
+ depends=('python' 'python-future')
+ cd "${srcdir}/virustotal-api-${pkgver}"
+ python setup.py install --root "${pkgdir}" --optimize=1
}
package_python2-virustotal-api() {
- depends=('python2')
- cd "$srcdir/$_pyname-$pkgver"
- python2 setup.py install -O1 --root=$pkgdir
+ depends=('python2' 'python2-future')
+ cd "${srcdir}/virustotal-api2-${pkgver}"
+ python2 setup.py install --root "${pkgdir}" --optimize=1
}
-# vim:set et sw=4 ts=4 tw=76:
+# vim:set et sw=2 ts=2 tw=79: