summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtakar Jašek2019-11-13 10:38:45 +0100
committerOtakar Jašek2019-11-13 10:38:45 +0100
commit7712f2de6d81d91076ef4871dc7c3e4bc50135c1 (patch)
tree877adbecbcd408c2bb7c68fe37e1c42f4735a1b5
parent56353a036fb7646f55e5126a1c839b664ef7abdc (diff)
downloadaur-7712f2de6d81d91076ef4871dc7c3e4bc50135c1.tar.gz
Drop Python 2 support. Less than 50 days till EOL for Python2
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD22
-rw-r--r--visdom2.conf1
3 files changed, 12 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58cd343a3416..990c95a3b5d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,40 +7,25 @@ pkgbase = python-visdom-git
license = CCPL:by-nc
makedepends = git
makedepends = python-setuptools
- makedepends = python2-setuptools
+ depends = python-websocket-client
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-requests
+ depends = python-tornado
+ depends = python-pyzmq
+ depends = python-six
+ depends = python-jsonpatch
+ depends = python-pillow
options = !emptydirs
source = git+https://github.com/facebookresearch/visdom.git
source = visdom.conf
- source = visdom2.conf
source = visdom.group.conf
sha256sums = SKIP
sha256sums = f795c8a3185282b366e7942b07b5ac74b9c293d1eb0f15727cf26905c1d7934e
- sha256sums = f795c8a3185282b366e7942b07b5ac74b9c293d1eb0f15727cf26905c1d7934e
sha256sums = d71fbfa6bb3feecfb1997a459da196f8a2f0f50b33428043921803d97db5562c
pkgname = python-visdom-git
install = visdom.install
- depends = python-websocket-client
- depends = python-numpy
- depends = python-scipy
- depends = python-requests
- depends = python-tornado
- depends = python-pyzmq
- depends = python-six
- depends = python-jsonpatch
provides = python-visdom
conflicts = python-visdom
-pkgname = python2-visdom-git
- install = visdom.install
- depends = python2-websocket-client
- depends = python2-numpy
- depends = python2-scipy
- depends = python2-requests
- depends = python2-tornado
- depends = python2-pyzmq
- depends = python2-six
- depends = python2-jsonpatch
- provides = python2-visdom
- conflicts = python2-visdom
-
diff --git a/PKGBUILD b/PKGBUILD
index 8b7c944489a1..45b1aa44f45d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,23 @@
# Thanks to Jeremy "Ichimonji10" Audet <ichimonji10 at gmail dot com> for
# his PKGBUILD that served as a base for this one
-pkgbase=python-visdom-git
_pkgbase="visdom"
-pkgname=(python-visdom-git python2-visdom-git)
+pkgname=python-visdom-git
pkgver=r288.bb0ab59
pkgrel=1
arch=(any)
url='https://github.com/facebookresearch/visdom'
pkgdesc='Visualization tool for Pytorch by Facebook'
license=(CCPL:by-nc)
+depends=('python-websocket-client' 'python-numpy' 'python-scipy' 'python-requests' 'python-tornado' 'python-pyzmq' 'python-six' 'python-jsonpatch' 'python-pillow')
makedepends=(
'git'
'python-setuptools'
- 'python2-setuptools'
)
options=(!emptydirs)
-source=("git+https://github.com/facebookresearch/visdom.git" "visdom.conf" "visdom2.conf" "visdom.group.conf")
+source=("git+https://github.com/facebookresearch/visdom.git" "visdom.conf" "visdom.group.conf")
sha256sums=('SKIP'
'f795c8a3185282b366e7942b07b5ac74b9c293d1eb0f15727cf26905c1d7934e'
- 'f795c8a3185282b366e7942b07b5ac74b9c293d1eb0f15727cf26905c1d7934e'
'd71fbfa6bb3feecfb1997a459da196f8a2f0f50b33428043921803d97db5562c')
pkgver() {
@@ -30,7 +28,6 @@ pkgver() {
}
package_python-visdom-git() {
-depends=('python-websocket-client' 'python-numpy' 'python-scipy' 'python-requests' 'python-tornado' 'python-pyzmq' 'python-six' 'python-jsonpatch')
provides=('python-visdom')
conflicts=('python-visdom')
install='visdom.install'
@@ -40,16 +37,3 @@ install='visdom.install'
install -Dm 644 "${srcdir}/${_pkgbase}.group.conf" "${pkgdir}/usr/lib/sysusers.d/${_pkgbase}.group.conf"
install -Dm 644 "${srcdir}/${_pkgbase}.conf" "${pkgdir}/usr/lib/tmpfiles.d/${_pkgbase}.conf"
}
-
-package_python2-visdom-git() {
-depends=('python2-websocket-client' 'python2-numpy' 'python2-scipy' 'python2-requests' 'python2-tornado' 'python2-pyzmq' 'python2-six' 'python2-jsonpatch')
-provides=('python2-visdom')
-conflicts=('python2-visdom')
-install='visdom.install'
- cd "${srcdir}/${_pkgbase}"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
- mv "${pkgdir}/usr/bin/visdom" "${pkgdir}/usr/bin/visdom2"
- install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 "${srcdir}/${_pkgbase}.group.conf" "${pkgdir}/usr/lib/sysusers.d/${_pkgbase}.group.conf"
- install -Dm 644 "${srcdir}/${_pkgbase}2.conf" "${pkgdir}/usr/lib/tmpfiles.d/${_pkgbase}.conf"
-}
diff --git a/visdom2.conf b/visdom2.conf
deleted file mode 100644
index 73bc0ddbf1a3..000000000000
--- a/visdom2.conf
+++ /dev/null
@@ -1 +0,0 @@
-Z /usr/lib/python3.7/site-packages/visdom/static/ 775 - visdom