summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-14 05:23:54 +1100
committerPumpkinCheshire2020-11-14 05:23:54 +1100
commit0a2d612db032def2b8ef845e5c375f2e898903a1 (patch)
treeb0aaeddbf1733f9e4a6fff89afde2acd9655a1d4
downloadaur-0a2d612db032def2b8ef845e5c375f2e898903a1.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bbb0f79f62cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-viztracer
+ pkgdesc = VizTracer is a low-overhead logging/debugging/profiling tool that can trace and visualize your python code execution.
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = https://github.com/gaogaotiantian/viztracer
+ arch = x86_64
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ optdepends = python-rich: Full function support
+ optdepends = python-orjson: Full function support
+ optdepends = chromium: browser to open html results
+ source = https://files.pythonhosted.org/packages/source/v/viztracer/viztracer-0.10.0.tar.gz
+ sha256sums = a75a836430bf4c4e39890650a5ad855b3dc695ba855006c02633cc9b4f8645f4
+
+pkgname = python-viztracer
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efc974ddccf2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: pumpkincheshire <sollyonzou@gmail.com>
+
+pkgname=python-viztracer
+_name=viztracer
+pkgver=0.10.0
+pkgrel=1
+pkgdesc='VizTracer is a low-overhead logging/debugging/profiling tool that can trace and visualize your python code execution.'
+arch=('x86_64')
+url='https://github.com/gaogaotiantian/viztracer'
+license=('Apache')
+depends=('python')
+makedepends=('python-setuptools')
+optdepends=('python-rich: Full function support'
+ 'python-orjson: Full function support'
+ 'chromium: browser to open html results')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('a75a836430bf4c4e39890650a5ad855b3dc695ba855006c02633cc9b4f8645f4')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # install -Dm644 $scrdir/README* "${pkgdir}/usr/share/doc/${pkgname}/README"
+}