summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrejs Mivreņiks2015-06-08 12:04:01 +0300
committerAndrejs Mivreņiks2015-06-08 12:04:01 +0300
commit48102e6c55676ead62d04c1fc96dcbd83b252f34 (patch)
treeb4d81964a63478ddbf58008c8d67100f7a9dff8d
downloadaur-48102e6c55676ead62d04c1fc96dcbd83b252f34.tar.gz
Transition to AUR4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ecfdaffacbe2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-vk
+ pkgdesc = A Python wrapper around the VK.com/VKontakte.ru API.
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://github.com/dimka665/vk
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-requests
+ source = https://github.com/dimka665/vk/archive/1.5.tar.gz
+ sha256sums = ff250c29414c61e21d041b0e264be78bdbe7a91a29562ce0aeec9c1660e548b6
+
+pkgname = python-vk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff1e907ea4d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Andrejs Mivreņiks <gim at fastmail dot fm>
+pkgname=python-vk
+pkgver=1.5
+pkgrel=1
+pkgdesc='A Python wrapper around the VK.com/VKontakte.ru API.'
+arch=('any')
+url="https://github.com/dimka665/vk"
+license=('MIT')
+depends=('python' 'python-requests')
+makedepends=('python-setuptools')
+source=("https://github.com/dimka665/vk/archive/${pkgver}.tar.gz")
+sha256sums=('ff250c29414c61e21d041b0e264be78bdbe7a91a29562ce0aeec9c1660e548b6')
+
+build() {
+ cd "$srcdir/vk-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/vk-$pkgver"
+ python setup.py install --root=$pkgdir --optimize=1
+}
+# vim:set ts=2 sw=2 et: