summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Lee2015-11-07 12:06:54 -0800
committerAntony Lee2015-11-07 12:06:54 -0800
commit1b1a51e701e6c858662e0df20edf712caad0dfb4 (patch)
treee853108b51239830cf24c13cda421403883e3544
downloadaur-1b1a51e701e6c858662e0df20edf712caad0dfb4.tar.gz
Initial commit.
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD26
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ddb9d91b5d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-vmprof
+ pkgdesc = Python's vmprof client
+ pkgver = 0.1.5.5
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/vmprof
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = python-click
+ depends = python-six
+ depends = libdwarf
+ depends = libelf
+ depends = libunwind
+ source = https://pypi.python.org/packages/source/v/vmprof/vmprof-0.1.5.5.tar.gz
+ source = LICENSE
+ md5sums = c4a058ba74cebce39b9de3367a1fb089
+ md5sums = f4a0384fe9ff04541fbcb583b5dfd3c9
+
+pkgname = python-vmprof
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..2afeea16c604
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+License
+=======
+
+
+ The MIT License
+
+ Permission is hereby granted, free of charge, to any person
+ obtaining a copy of this software and associated documentation
+ files (the "Software"), to deal in the Software without
+ restriction, including without limitation the rights to use,
+ copy, modify, merge, publish, distribute, sublicense, and/or
+ sell copies of the Software, and to permit persons to whom the
+ Software is furnished to do so, subject to the following conditions:
+
+ The above copyright notice and this permission notice shall be included
+ in all copies or substantial portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+ OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+ THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+ FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b41c2b9a96a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
+
+_pyname=vmprof
+pkgname=python-$_pyname
+pkgver=0.1.5.5
+pkgrel=1
+pkgdesc="Python's vmprof client"
+url='https://pypi.python.org/pypi/vmprof'
+depends=('python-click' 'python-six' 'libdwarf' 'libelf' 'libunwind')
+license=('MIT')
+arch=('i686' 'x86_64')
+source=("https://pypi.python.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz"
+ 'LICENSE')
+md5sums=('c4a058ba74cebce39b9de3367a1fb089'
+ 'f4a0384fe9ff04541fbcb583b5dfd3c9')
+
+build() {
+ cd $srcdir/$_pyname-$pkgver
+ python setup.py build
+}
+
+package() {
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd $srcdir/$_pyname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}