summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-06 02:33:00 -0500
committerLuis Martinez2021-10-06 02:33:00 -0500
commitac907dc7b82ab6c311785f6c04fc7db9a57b5a99 (patch)
tree228b9b0fbe0f21a4894e4faa2cd412febb347345
downloadaur-ac907dc7b82ab6c311785f6c04fc7db9a57b5a99.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e446767b39f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-vt-py
+ pkgdesc = Official Python 3 client library for VirusTotal's REST API
+ pkgver = 0.7.5
+ pkgrel = 1
+ url = https://github.com/virustotal/vt-py
+ arch = any
+ license = Apache
+ checkdepends = python-pytest-httpserver
+ checkdepends = python-pytest-asyncio
+ makedepends = python-pytest-runner
+ makedepends = python-setuptools
+ depends = python-aiohttp
+ provides = python-virustotal
+ replaces = python-virustotal-api
+ source = python-vt-py-0.7.5.tar.gz::https://github.com/virustotal/vt-py/archive/0.7.5.tar.gz
+ sha256sums = ec2b5702ffeb032f724bd2c0525967c334debb4aff4d625b77a76623ead48cc3
+
+pkgname = python-vt-py
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..707bd21d1e90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=python-vt-py
+pkgver=0.7.5
+pkgrel=1
+pkgdesc="Official Python 3 client library for VirusTotal's REST API"
+arch=('any')
+url="https://github.com/virustotal/vt-py"
+license=('Apache')
+depends=('python-aiohttp')
+makedepends=('python-pytest-runner' 'python-setuptools')
+checkdepends=('python-pytest-httpserver' 'python-pytest-asyncio')
+provides=('python-virustotal')
+replaces=('python-virustotal-api')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('ec2b5702ffeb032f724bd2c0525967c334debb4aff4d625b77a76623ead48cc3')
+
+build() {
+ cd "vt-py-$pkgver"
+ python setup.py build
+}
+
+check() {
+ cd "vt-py-$pkgver"
+ python setup.py pytest
+}
+
+package() {
+ cd "vt-py-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}