summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Forencich2015-07-20 11:49:57 -0700
committerAlex Forencich2015-07-20 11:49:57 -0700
commit0a44ba1a470b4cde6e3186e518f5e884ccd477e8 (patch)
tree60c72eba77f53836d52d7cf8783d8be7e3a78524
downloadaur-0a44ba1a470b4cde6e3186e518f5e884ccd477e8.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2041c32caf69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-vxi11
+ pkgdesc = A Python VXI-11 driver for controlling instruments over Ethernet.
+ pkgver = 0.8
+ pkgrel = 1
+ url = https://github.com/python-ivi/python-vxi11
+ arch = any
+ license = MIT
+ depends = python
+ source = python-vxi11-0.8.tar.gz::https://github.com/python-ivi/python-vxi11/archive/v0.8.tar.gz
+ md5sums = 46db7d4d6c93ae0bcafd23958010f3df
+
+pkgname = python-vxi11
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bb091cac585
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alex Forencich <alex@alexforencich.com>
+pkgname=python-vxi11
+pkgver=0.8
+pkgrel=1
+pkgdesc="A Python VXI-11 driver for controlling instruments over Ethernet."
+arch=('any')
+url="https://github.com/python-ivi/python-vxi11"
+license=('MIT')
+depends=('python')
+
+source=("python-vxi11-$pkgver.tar.gz::https://github.com/python-ivi/python-vxi11/archive/v$pkgver.tar.gz")
+md5sums=('46db7d4d6c93ae0bcafd23958010f3df')
+
+build() {
+ cd "$srcdir/python-vxi11-$pkgver"
+ sed -i "s/'vxi11-cli/'python-vxi11-cli/" setup.py
+}
+
+package() {
+ cd "$srcdir/python-vxi11-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ cd "$pkgdir"
+ cd usr
+ cd bin
+ ln -s python-vxi11-cli vxi11-cli
+}
+