summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuliette Monsel2019-02-19 17:52:35 +0100
committerJuliette Monsel2019-02-19 17:52:35 +0100
commitbf2668d234ebf925628bde98dba69eac6097d0f5 (patch)
treed46ee256d3c619c987feb601d1574dd00acfc657
downloadaur-bf2668d234ebf925628bde98dba69eac6097d0f5.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9700d8a145b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-wadllib
+ pkgdesc = Python 3 library for navigating WADL files. The Web Application Description Language is an XML vocabulary for describing the capabilities of HTTP resources.
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://launchpad.net/wadllib
+ arch = any
+ license = LGPL3
+ makedepends = python-setuptools
+ depends = python-lazr-uri
+ depends = python-setuptools
+ depends = python-simplejson
+ source = python-wadllib-1.3.2.tar.gz::https://launchpad.net/wadllib/trunk/1.3.2/+download/wadllib-1.3.2.tar.gz
+ source = python-wadllib-1.3.2.tar.gz.asc::https://launchpad.net/wadllib/trunk/1.3.2/+download/wadllib-1.3.2.tar.gz.asc
+ validpgpkeys = 8417157EDBE73D9EAC1E539B126EB563A74B06BF
+ sha256sums = 140e43fc16d4352a98a90a450c6326bee5e6de73ae373a569947f3b505405034
+ sha256sums = SKIP
+
+pkgname = python-wadllib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a8f484369a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Juliette Monsel <j_4321 at protonmail dot com>
+# based on the python2-wadllib PKGBUILD by ValHue <vhuelamo at gmail dot com>
+
+_pkgname="wadllib"
+pkgname=("python-wadllib")
+pkgver="1.3.2"
+pkgrel="1"
+pkgdesc="Python 3 library for navigating WADL files. The Web Application Description Language is an XML vocabulary for describing the capabilities of HTTP resources."
+arch=('any')
+url="https://launchpad.net/wadllib"
+license=('LGPL3')
+makedepends=('python-setuptools')
+depends=('python-lazr-uri' 'python-setuptools' 'python-simplejson')
+source=("${pkgname}-${pkgver}.tar.gz::https://launchpad.net/$_pkgname/trunk/$pkgver/+download/$_pkgname-$pkgver.tar.gz"
+ "${pkgname}-${pkgver}.tar.gz.asc::https://launchpad.net/$_pkgname/trunk/$pkgver/+download/$_pkgname-$pkgver.tar.gz.asc")
+sha256sums=('140e43fc16d4352a98a90a450c6326bee5e6de73ae373a569947f3b505405034'
+ 'SKIP')
+validpgpkeys=('8417157EDBE73D9EAC1E539B126EB563A74B06BF')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}