summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2019-08-30 17:54:41 +0200
committerDario Ostuni2019-08-30 17:54:41 +0200
commitde63e3390163706bc19b76d08790472ff7170039 (patch)
treeab293c44974b0e8847ca0b3160931a1e50c7661a
downloadaur-de63e3390163706bc19b76d08790472ff7170039.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD18
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00a4cedbaacf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-wasmtime
+ pkgdesc = Python 3 extension for interface with Wasmtime/Cranelift.
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/CraneStation/wasmtime
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = APACHE2
+ makedepends = rustup
+ depends = python
+ depends = python-setuptools
+ depends = python-wheel
+ depends = python-setuptools-rust
+ options = !emptydirs
+ source = https://github.com/CraneStation/wasmtime/archive/v0.3.0.tar.gz
+ sha384sums = c043bf58f24a174d832b14b4aa1a6de17cd608648753da65c64f33254e79df913ce0e709abcd9645e71ebed4c2134360
+
+pkgname = python-wasmtime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c3841b4f2f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Dario Ostuni <another.code.996@gmail.com>
+pkgname=python-wasmtime
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Python 3 extension for interface with Wasmtime/Cranelift."
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url="https://github.com/CraneStation/wasmtime"
+license=('APACHE2')
+depends=('python' 'python-setuptools' 'python-wheel' 'python-setuptools-rust')
+makedepends=('rustup')
+options=(!emptydirs)
+source=("https://github.com/CraneStation/wasmtime/archive/v${pkgver}.tar.gz")
+sha384sums=('c043bf58f24a174d832b14b4aa1a6de17cd608648753da65c64f33254e79df913ce0e709abcd9645e71ebed4c2134360')
+
+package() {
+ cd "$srcdir/wasmtime-${pkgver}/misc/wasmtime-py"
+ rustup run nightly python setup.py install --root="$pkgdir/" --optimize=1
+}