summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Yantis2015-06-11 08:25:41 -0700
committerJonathan Yantis2015-06-11 08:25:41 -0700
commit6dfa6f362ef316ed147d293df9a54a23e49c4d77 (patch)
treeb071eb004bdd28b2d22004a0917b72a51df023b4
downloadaur-6dfa6f362ef316ed147d293df9a54a23e49c4d77.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD59
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb8630f1bb59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-watchdog-git
+ pkgdesc = Python 3 library to monitor filesystem events.
+ pkgver = 0.8.3.r1073.abb1072
+ pkgrel = 2
+ url = https://github.com/gorakhargosh/watchdog
+ arch = any
+ license = custom
+ makedepends = git
+ depends = python
+ depends = python-setuptools
+ depends = python-pathtools
+ depends = python-yaml
+ depends = python-argh
+ provides = python-watchdog
+ conflicts = python-watchdog
+ source = git+https://github.com/gorakhargosh/watchdog.git
+ sha256sums = SKIP
+
+pkgname = python-watchdog-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfe208afc0f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: jyantis <yantis@yantis.net>
+# Contributor: Sandro Munda <munda.sandro@gmail.com>
+
+pkgname=python-watchdog-git
+pkgver=0.8.3.r1073.abb1072
+pkgrel=2
+pkgdesc='Python 3 library to monitor filesystem events.'
+arch=('any')
+url='https://github.com/gorakhargosh/watchdog'
+license=('custom')
+depends=('python'
+ 'python-setuptools'
+ 'python-pathtools'
+ 'python-yaml'
+ 'python-argh'
+ )
+source=('git+https://github.com/gorakhargosh/watchdog.git')
+sha256sums=('SKIP')
+makedepends=('git')
+provides=('python-watchdog')
+
+conflicts=('python-watchdog')
+
+pkgver() {
+ cd watchdog
+
+ printf "%s." "$(grep -Ri "VERSION_MAJOR = " src/watchdog/version.py | awk 'BEGIN {FS = " "} {print $3}')"
+ printf "%s." "$(grep -Ri "VERSION_MINOR = " src/watchdog/version.py | awk 'BEGIN {FS = " "} {print $3}')"
+ printf "%s." "$(grep -Ri "VERSION_BUILD = " src/watchdog/version.py | awk 'BEGIN {FS = " "} {print $3}')"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd watchdog
+ python setup.py build
+}
+
+# Half the time check fails on one of the 51 tests for delayed queue
+# check() {
+# cd watchdog
+# python setup.py test --verbose
+#}
+
+package() {
+ cd watchdog
+
+ # We don't need anything related to git in the package
+ rm -rf .git*
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ # Install License
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install Documentation
+ install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}
+
+# vim:set ts=2 sw=2 et: