summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Langlois2015-09-24 14:17:25 -0400
committerTim Langlois2015-09-24 14:17:25 -0400
commit545350ae758038527e0004cdeb48d9b65dc44609 (patch)
treefc4765d378b3f713baa32a545ecbf925e24f5bb7
downloadaur-545350ae758038527e0004cdeb48d9b65dc44609.tar.gz
Initial package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81efee8390e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-wavefile
+ pkgdesc = Pythonic libsndfile wrapper to read and write audio files.
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://github.com/vokimon/python-wavefile
+ arch = any
+ license = GPL3
+ checkdepends = python-numpy
+ checkdepends = python-pyaudio
+ makedepends = python-setuptools
+ source = https://pypi.python.org/packages/source/w/wavefile/wavefile-1.4.tar.gz
+ md5sums = 4427a9a24536bf759e9e791d4424c6b4
+
+pkgname = python-wavefile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7fed1f18466
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Tim Langlois <trl54@cornell.edu>
+
+basename=wavefile
+pkgname=python-${basename}
+pkgver=1.4
+pkgrel=1
+arch=('any')
+license=('GPL3')
+pkgdesc="Pythonic libsndfile wrapper to read and write audio files."
+url="https://github.com/vokimon/python-wavefile"
+makedepends=('python-setuptools')
+checkdepends=('python-numpy' 'python-pyaudio')
+source=("https://pypi.python.org/packages/source/w/wavefile/wavefile-1.4.tar.gz")
+md5sums=('4427a9a24536bf759e9e791d4424c6b4')
+
+build() {
+ cd "${srcdir}/${basename}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${basename}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}