summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Willemse2016-01-24 12:44:45 +0100
committerTom Willemse2016-01-24 12:44:45 +0100
commit67bbbee6886144c69a0ee22c1691668e9dab2512 (patch)
treef71e21d3339026385dba3850b3647a92911cb027
downloadaur-python-wdocker.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0e05683d654
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Sun Jan 24 11:44:28 UTC 2016
+pkgbase = python-wdocker
+ pkgdesc = Define docker commands in your Dockerfile
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/wdocker
+ arch = any
+ license = custom:ISC
+ depends = python
+ source = http://pypi.python.org/packages/source/w/wdocker/wdocker-0.2.0.tar.gz
+ md5sums = d873202d66b1d99a13004009e9f36d25
+
+pkgname = python-wdocker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..faaff78b9dda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Tom Willemse <tom@ryuslash.org>
+
+python=python
+name=wdocker
+
+pkgname=$python-wdocker
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Define docker commands in your Dockerfile"
+depends=('python')
+arch=('any')
+source=(http://pypi.python.org/packages/source/w/wdocker/$name-$pkgver.tar.gz)
+md5sums=('d873202d66b1d99a13004009e9f36d25')
+url="https://pypi.python.org/pypi/wdocker"
+license=("custom:ISC")
+
+build() {
+ cd "${srcdir}/${name}-${pkgver}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${srcdir}/${name}-${pkgver}"
+ python setup.py install --root="$pkgdir"
+
+ install -Dm644 "${srcdir}/${name}-${pkgver}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/${name}-${pkgver}/README.rst" \
+ "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}