summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas K2015-08-19 22:43:21 +0200
committerLukas K2015-08-19 22:43:21 +0200
commitaa0e618eeffff50981d9f0d891fc52f813a3110e (patch)
tree6a9d80df194a5cf5117fd8b33af8f5e464cdf85f
downloadaur-aa0e618eeffff50981d9f0d891fc52f813a3110e.tar.gz
init
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a37d9e98073
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-webcolors
+ pkgdesc = Library for working with HTML/CSS color formats in Python
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://blockdiag.com/en/seqdiag/index.html
+ arch = any
+ license = bsd
+ depends = python
+ source = https://github.com/ubernostrum/webcolors/archive/1.5.tar.gz
+ md5sums = 02f5985cd0600090b3afdecd649abccc
+
+pkgname = python-webcolors
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3551d65a7c32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Lukas K. <lu at 0x83 dot eu>
+
+_libname=webcolors
+pkgname=python-$_libname
+pkgver=1.5
+pkgrel=1
+pkgdesc=" Library for working with HTML/CSS color formats in Python"
+arch=("any")
+url="http://blockdiag.com/en/seqdiag/index.html"
+license=('bsd')
+depends=('python')
+source=("https://github.com/ubernostrum/$_libname/archive/$pkgver.tar.gz")
+md5sums=("02f5985cd0600090b3afdecd649abccc")
+
+package() {
+ cd "$srcdir/$_libname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: