summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2018-09-11 13:45:13 +0300
committerChristoph Fink2018-09-11 13:45:13 +0300
commit77821284dea229fc3b322d1043d7565d10432f24 (patch)
tree6bb7a46598a93cae317686bd6e42f32c736a8403
downloadaur-77821284dea229fc3b322d1043d7565d10432f24.tar.gz
v0.1.5
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD53
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc57051bb2b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-webhoseio
+ pkgdesc = Simple client library for the webhose.io REST API
+ pkgver = 0.1.5
+ pkgrel = 0
+ url = https://github.com/Webhose/webhoseio-python/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://files.pythonhosted.org/packages/ed/5b/6226f7cdf021ad1faf9967dc58247161233e09aa36ba71a6e4dab75fd7f2/webhose-0.1.5.tar.gz
+ sha256sums = 3d96bda569e7a36da2884ecff03c26a5f3b9267176114ec18aa9f9d3cbddf238
+
+pkgname = python-webhoseio
+ depends = python
+ depends = python-requests
+
+pkgname = python2-webhoseio
+ depends = python2
+ depends = python2-requests
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fab4ae638e97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: peippo <christoph.fink@gmail.com>
+
+pkgbase=python-webhoseio
+pkgname=('python-webhoseio' 'python2-webhoseio')
+pkgver=0.1.5
+pkgrel=0
+
+pkgdesc="Simple client library for the webhose.io REST API"
+url="https://github.com/Webhose/webhoseio-python/"
+license=('MIT')
+
+arch=('any')
+makedepends=('python-setuptools' 'python2-setuptools')
+
+source=("https://files.pythonhosted.org/packages/ed/5b/6226f7cdf021ad1faf9967dc58247161233e09aa36ba71a6e4dab75fd7f2/webhose-0.1.5.tar.gz")
+sha256sums=('3d96bda569e7a36da2884ecff03c26a5f3b9267176114ec18aa9f9d3cbddf238')
+
+prepare() {
+ rm -r webhose-$pkgver/*.egg-info
+ cp -a webhose-$pkgver{,-py2}
+}
+
+build() {
+ cd "$srcdir"/webhose-$pkgver
+ python setup.py build
+
+ cd "$srcdir"/webhose-$pkgver-py2
+ python2 setup.py build
+}
+
+check() {
+ cd "$srcdir"/webhose-$pkgver
+ python setup.py test
+
+ cd "$srcdir"/webhose-$pkgver-py2
+ python2 setup.py test
+}
+
+package_python-webhoseio() {
+ depends=('python' 'python-requests')
+
+ cd webhose-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.rst
+}
+
+package_python2-webhoseio() {
+ depends=('python2' 'python2-requests')
+
+ cd webhose-$pkgver-py2
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.rst
+}