summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpeippo2019-01-25 11:23:36 +0000
committerpeippo2019-01-25 11:23:36 +0000
commitdd994469b292f8d73eaac3013f08b570ba74cd5b (patch)
treedebcfad1dc467c46548641f91819bafbd5a7ef07
downloadaur-dd994469b292f8d73eaac3013f08b570ba74cd5b.tar.gz
python-webis-0.2.1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD43
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..073ddb60c00f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-webis
+ pkgdesc = Python wrapper for the webis Twitter sentiment identification tool
+ pkgver = 0.2.1
+ pkgrel = 0
+ url = https://gitlab.com/christoph.fink/python-webis
+ arch = any
+ license = GPLv3
+ makedepends = java-environment
+ makedepends = java-runtime
+ makedepends = python-gitpython
+ makedepends = python-setuptools
+ depends = java-environment
+ depends = java-runtime
+ depends = python-emojientities
+ depends = python-gitpython
+ depends = python-pandas
+ depends = python-pyjnius
+ source = https://gitlab.com/christoph.fink/python-webis/uploads/9772ef8d4e8644679cc6f00d920b4346/webis-0.2.1.tar.gz
+ sha256sums = 44f5fb55655c77a39f1a351100bc361bda88d33b6c5ab612798b7389a11f0a41
+
+pkgname = python-webis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d73c4618f3ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: peippo <christoph.fink@gmail.com>
+
+pkgname=python-webis
+pkgver=0.2.1
+pkgrel=0
+
+pkgdesc="Python wrapper for the webis Twitter sentiment identification tool"
+url="https://gitlab.com/christoph.fink/python-webis"
+license=("GPLv3")
+
+arch=("any")
+makedepends=(
+ "java-environment"
+ "java-runtime"
+ "python-gitpython"
+ "python-setuptools"
+)
+depends=(
+ "java-environment"
+ "java-runtime"
+ "python-emojientities"
+ "python-gitpython"
+ "python-pandas"
+ "python-pyjnius"
+)
+
+source=("https://gitlab.com/christoph.fink/python-webis/uploads/9772ef8d4e8644679cc6f00d920b4346/webis-0.2.1.tar.gz")
+sha256sums=("44f5fb55655c77a39f1a351100bc361bda88d33b6c5ab612798b7389a11f0a41")
+
+prepare() {
+ rm -Rf "${srcdir}/*/*.egg-info"
+}
+
+build() {
+ cd "${srcdir}/webis-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/webis-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+}