summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcus Hoffmann2020-10-15 18:50:48 +0200
committerMarcus Hoffmann2020-10-15 18:50:48 +0200
commitb524223a1ecc7f0fd35333073d6452f0be2a7705 (patch)
treea1872247896fdc7a786da020fed9fd53d63502e9
downloadaur-b524223a1ecc7f0fd35333073d6452f0be2a7705.tar.gz
new package: weblate-language-data
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fab5e47d459
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-weblate-language-data
+ pkgdesc = Language definitions used by Weblate
+ pkgver = 2020.10
+ pkgrel = 1
+ url = https://github.com/WeblateOrg/language-data
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/WeblateOrg/language-data/archive/2020.10.tar.gz
+ sha256sums = 486dfef779764ea63c88b82f72f9ebfc85725dda7320c73568a9c1ff07326ea3
+
+pkgname = python-weblate-language-data
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb6cb8669549
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Marcus Hoffmann <bubu@bubu1.eu>
+_pkgname=language-data
+pkgname=python-weblate-language-data
+pkgver=2020.10
+pkgrel=1
+pkgdesc="Language definitions used by Weblate"
+url="https://github.com/WeblateOrg/language-data"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://github.com/WeblateOrg/language-data/archive/${pkgver}.tar.gz")
+
+sha256sums=('486dfef779764ea63c88b82f72f9ebfc85725dda7320c73568a9c1ff07326ea3')
+
+#check() {
+# pytest
+#}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}