summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcus Hoffmann2020-06-17 23:42:37 +0200
committerMarcus Hoffmann2020-06-17 23:42:37 +0200
commit17113c44e0eb0efc98068c11abf346a3b99bd464 (patch)
tree98b2239c768745344ca34f980f56b234d9fa4d18
downloadaur-17113c44e0eb0efc98068c11abf346a3b99bd464.tar.gz
inital package
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7a79c9d5707
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-weblate_schemas
+ pkgdesc = Schemas used in Weblate
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/WeblateOrg/weblate_schemas
+ arch = any
+ license = MIT
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = python
+ depends = python-jsonschema
+ source = https://github.com/WeblateOrg/weblate_schemas/archive/0.3.tar.gz
+ sha256sums = 479c2d629ae1e972e6a9468f94de5798d9dac974054c293fd06d375cffe32614
+
+pkgname = python-weblate_schemas
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64bbd1b11f9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Marcus Hoffmann <bubu@bubu1.eu>
+
+_pkgname=weblate_schemas
+pkgname=python-weblate_schemas
+pkgver=0.3
+pkgrel=1
+pkgdesc="Schemas used in Weblate"
+url="https://github.com/WeblateOrg/weblate_schemas"
+depends=('python' 'python-jsonschema')
+checkdepends=('python-pytest')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://github.com/WeblateOrg/${_pkgname}/archive/${pkgver}.tar.gz")
+
+sha256sums=('479c2d629ae1e972e6a9468f94de5798d9dac974054c293fd06d375cffe32614')
+
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ pytest
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}