summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2015-10-25 18:15:24 +1100
committerMatthew Gamble2015-10-25 18:15:24 +1100
commit21dc40d9bbc0a636cf69cf180f1e6be9bc4ede1e (patch)
tree35a109ff853df160eb99fc34734511039ce37df9
downloadaur-21dc40d9bbc0a636cf69cf180f1e6be9bc4ede1e.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ab4cb6db91d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-webpagecache
+ pkgdesc = A utility class for downloading webpages and storing them in an SQLite3 database as a cache.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/djmattyg007/python-webpagecache
+ arch = any
+ license = UNLICENSE
+ makedepends = python-setuptools
+ depends = python
+ depends = python-wire
+ source = https://github.com/djmattyg007/python-webpagecache/archive/1.0.0.zip
+ sha256sums = 53803a864b529b7b82ee3a92f4bab0bb1a706d086a3fc06a763b0bdda2b01b48
+
+pkgname = python-webpagecache
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed9e6f96ed4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Matthew Gamble
+
+pkgname=python-webpagecache
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A utility class for downloading webpages and storing them in an SQLite3 database as a cache."
+arch=('any')
+url='https://github.com/djmattyg007/python-webpagecache'
+license=('UNLICENSE')
+depends=('python' 'python-wire')
+makedepends=('python-setuptools')
+source=("https://github.com/djmattyg007/python-webpagecache/archive/${pkgver}.zip")
+sha256sums=('53803a864b529b7b82ee3a92f4bab0bb1a706d086a3fc06a763b0bdda2b01b48')
+
+package() {
+ cd "python-webpagecache-$pkgver"
+ python setup.py install --root="$pkgdir"
+}