summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenden Davidson2020-06-20 18:05:38 -0500
committerBrenden Davidson2020-06-20 18:05:38 -0500
commit3cd2b6a51b61eff4d976791022624a1c2f26cac4 (patch)
tree7a761d1d8b815ea3454c759f75fc75f761332639
parentf202987e6127e457017e533e7bf75a068e70e4f9 (diff)
downloadaur-3cd2b6a51b61eff4d976791022624a1c2f26cac4.tar.gz
Disabled unit tests due to test database requirement.
Signed-off-by: Brenden Davidson <davidson.brenden15@gmail.com>
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
2 files changed, 21 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b175dcb864ef..eda0eb943d97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,20 @@
pkgbase = python-webpy
pkgdesc = A web framework for Python
pkgver = 0.51
- pkgrel = 2
+ pkgrel = 3
url = https://webpy.org/
arch = any
license = custom
checkdepends = python-pytest>=4.6.2
+ checkdepends = Omitted
+ checkdepends = to
+ checkdepends = disable
+ checkdepends = DB
+ checkdepends = tests
+ checkdepends = python-dbutils
+ checkdepends = python-pymysql>=0.9.3
+ checkdepends = python-mysql-connector>=8.0.19
+ checkdepends = python-psycopg2>=2.8.4
depends = python-cheroot>=6.0.0
source = python-webpy-0.51.tar.gz::https://github.com/webpy/webpy/archive/0.51.tar.gz
sha256sums = 550ed5fb18c7626c578cc2119fd45a9a898b7815fc81a4ac85ae2ed383a0ec5f
diff --git a/PKGBUILD b/PKGBUILD
index 7b70c91416b9..8c01c241d8f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Brenden Davidson <davidson.brenden15@gmail.com>
pkgname=python-webpy
pkgver=0.51
-pkgrel=2
+pkgrel=3
pkgdesc="A web framework for Python"
arch=("any")
url="https://webpy.org/"
@@ -16,11 +16,11 @@ depends=(
checkdepends=(
"python-pytest>=4.6.2"
- # Omitted to disable DB tests
- # "python-dbutils"
- # "python-pymysql>=0.9.3"
- # "python-mysql-connector>=8.0.19"
- # "python-psycopg2>=2.8.4"
+ Omitted to disable DB tests
+ "python-dbutils"
+ "python-pymysql>=0.9.3"
+ "python-mysql-connector>=8.0.19"
+ "python-psycopg2>=2.8.4"
)
source=(
@@ -35,11 +35,11 @@ build() {
/usr/bin/python setup.py build
}
-# DB tests have been purposefully disabled by removing their dependencies.
-check() {
- cd "$_name-$pkgver"
- py.test tests $*
-}
+# Tests have been purposefully disabled due to them requiring a test database.
+# check() {
+# cd "$_name-$pkgver"
+# py.test tests $*
+# }
package() {
cd "$_name-$pkgver"