summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenden Davidson2020-06-19 12:47:16 -0500
committerBrenden Davidson2020-06-19 12:47:16 -0500
commitf202987e6127e457017e533e7bf75a068e70e4f9 (patch)
tree7fb0e4545a49f161fdee65d78f5b9c4987d2048a
parent5460f36197d89c23555683c2393d37a7a80a16ef (diff)
downloadaur-f202987e6127e457017e533e7bf75a068e70e4f9.tar.gz
Added missing dependencies and enabled tests.
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD26
3 files changed, 25 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b237ddd8d742..b175dcb864ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = python-webpy
pkgdesc = A web framework for Python
pkgver = 0.51
- pkgrel = 1
+ pkgrel = 2
url = https://webpy.org/
arch = any
license = custom
- depends = python
+ checkdepends = python-pytest>=4.6.2
+ depends = python-cheroot>=6.0.0
source = python-webpy-0.51.tar.gz::https://github.com/webpy/webpy/archive/0.51.tar.gz
sha256sums = 550ed5fb18c7626c578cc2119fd45a9a898b7815fc81a4ac85ae2ed383a0ec5f
diff --git a/.gitignore b/.gitignore
index 431946a11dbb..9a4b9489a6c3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-# We only want a handful of items, so we'l just whitelist what we want
+# We only want a handful of items, so we'll just whitelist what we want
./*
!PKGBUILD
!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index cfd37c54d585..7b70c91416b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Brenden Davidson <davidson.brenden15@gmail.com>
-pkgname="python-webpy"
-pkgver="0.51"
-pkgrel=1
+pkgname=python-webpy
+pkgver=0.51
+pkgrel=2
pkgdesc="A web framework for Python"
arch=("any")
url="https://webpy.org/"
@@ -10,14 +10,24 @@ license=('custom')
_name=${pkgname#python-}
depends=(
- "python"
+ "python-cheroot>=6.0.0"
+)
+
+checkdepends=(
+ "python-pytest>=4.6.2"
+
+ # Omitted to disable DB tests
+ # "python-dbutils"
+ # "python-pymysql>=0.9.3"
+ # "python-mysql-connector>=8.0.19"
+ # "python-psycopg2>=2.8.4"
)
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/webpy/webpy/archive/$pkgver.tar.gz"
)
sha256sums=(
- "550ed5fb18c7626c578cc2119fd45a9a898b7815fc81a4ac85ae2ed383a0ec5f"
+ "550ed5fb18c7626c578cc2119fd45a9a898b7815fc81a4ac85ae2ed383a0ec5f"
)
build() {
@@ -25,6 +35,12 @@ build() {
/usr/bin/python setup.py build
}
+# DB tests have been purposefully disabled by removing their dependencies.
+check() {
+ cd "$_name-$pkgver"
+ py.test tests $*
+}
+
package() {
cd "$_name-$pkgver"
/usr/bin/python setup.py install --root="$pkgdir" --optimize=1 --skip-build