summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomas Krizek2019-11-30 23:15:07 +0100
committerTomas Krizek2019-11-30 23:16:51 +0100
commit92ea6241cd3e49fbb356b2f367d7144a0f1668ef (patch)
tree16419dc75ee25ed3a19df473c93aab7eceffe7bd
downloadaur-92ea6241cd3e49fbb356b2f367d7144a0f1668ef.tar.gz
initial package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2688b201872a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-websharecli
+ pkgdesc = CLI utility to download from webshare.cz
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/tomaskrizek/websharecli
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-pyaml
+ depends = python-requests
+ depends = python-setuptools
+ depends = python-xmltodict
+ source = https://github.com/tomaskrizek/websharecli/archive/v1.1.1/websharecli-1.1.1.tar.gz
+ sha256sums = f1f075b5648dfa841407d19e8ed402914a8c4f20d6866b9da7718053594af901
+
+pkgname = python-websharecli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61abef99de32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Tomas Krizek <tomas.krizek@mailbox.org>
+_pkgname=websharecli
+pkgname=python-${_pkgname}
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="CLI utility to download from webshare.cz"
+arch=('any')
+url="https://github.com/tomaskrizek/${_pkgname}"
+license=('GPL3')
+depends=(
+ 'python'
+ 'python-pyaml'
+ 'python-requests'
+ 'python-setuptools'
+ 'python-xmltodict'
+)
+source=("https://github.com/tomaskrizek/${_pkgname}/archive/v${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('f1f075b5648dfa841407d19e8ed402914a8c4f20d6866b9da7718053594af901')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build install --root="${pkgdir}"
+}