summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornfnty2015-06-13 09:28:41 +0200
committernfnty2015-06-13 09:28:41 +0200
commit1bacca04d9b7ac6e28e787f7330b82e095093a7c (patch)
treef4828291c74b73456ec01fd4fa91c077767cca20
downloadaur-1bacca04d9b7ac6e28e787f7330b82e095093a7c.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..763fc05e98fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-websocket-client-git
+ pkgdesc = Websocket client for python
+ pkgver = r1
+ pkgrel = 1
+ url = https://github.com/liris/websocket-client
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-six
+ provides = python-websocket-client
+ conflicts = python-websocket-client
+ source = websocket-client::git+https://github.com/liris/websocket-client.git
+ sha512sums = SKIP
+
+pkgname = python-websocket-client-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1287955aac01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=('python-websocket-client-git')
+srcname='websocket-client'
+pkgver='r1'
+pkgrel='1'
+pkgdesc='Websocket client for python'
+arch=('any')
+url='https://github.com/liris/websocket-client'
+license=('GPL2')
+
+depends=('python-six')
+makedepends=('git' 'python-setuptools')
+provides=('python-websocket-client')
+conflicts=('python-websocket-client')
+
+source=("${srcname}::git+https://github.com/liris/websocket-client.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${srcname}"
+
+ printf 'r%s.%s\n' \
+ "$( git rev-list HEAD | wc --lines )" \
+ "$( git describe --always | sed 's/-/./g' )"
+}
+
+package() {
+ cd "${srcdir}/${srcname}"
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+}