summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Patelscheck2020-11-07 16:45:51 +0100
committerMoritz Patelscheck2020-11-07 16:45:51 +0100
commita0b595c3687df29940d21b469b0434893c3d08be (patch)
tree8ce891a1ee3915462c5b035734dc36e5c8de442f
downloadaur-a0b595c3687df29940d21b469b0434893c3d08be.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
-rw-r--r--sysusers.conf2
-rw-r--r--webssh.conf.d5
-rw-r--r--webssh.service10
5 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e5d16ec2a38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-webssh
+ pkgdesc = A SSH Web Front End
+ pkgver = 1.5.3
+ pkgrel = 1
+ url = https://github.com/huashengdun/webssh
+ arch = any
+ license = Apache
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python-tornado
+ depends = python-paramiko
+ backup = etc/conf.d/webssh
+ source = https://files.pythonhosted.org/packages/source/w/webssh/webssh-1.5.3.tar.gz
+ source = webssh.conf.d
+ source = webssh.service
+ source = sysusers.conf
+ sha256sums = 02ee8f13c8d89bc2e4129d01d72996fff664ae4715d016aec2e7d09ab1cb114e
+ sha256sums = d14c4c025468b8a4801b8f93dccad10da638934ec394bf34f9523bbcfe358286
+ sha256sums = cd7f5fc4b81fc1757fca6c00b5fadf1e24954d6c21682e6a3876b0de9e7be291
+ sha256sums = 5f4eca9aeb0744f06d14e90d0aae74d91a1953056c27a186c793bc104c22f832
+
+pkgname = python-webssh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bf8ce67df1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Moritz Patelscheck <moritz(at)patelscheck.de>
+_name=webssh
+pkgname=python-$_name
+pkgver=1.5.3
+pkgrel=1
+pkgdesc="A SSH Web Front End"
+arch=(any)
+url="https://github.com/huashengdun/webssh"
+license=("Apache")
+depends=("python-tornado" "python-paramiko")
+makedepends=("python" "python-setuptools")
+backup=(etc/conf.d/webssh)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ webssh.conf.d
+ webssh.service
+ sysusers.conf)
+sha256sums=('02ee8f13c8d89bc2e4129d01d72996fff664ae4715d016aec2e7d09ab1cb114e'
+ 'd14c4c025468b8a4801b8f93dccad10da638934ec394bf34f9523bbcfe358286'
+ 'cd7f5fc4b81fc1757fca6c00b5fadf1e24954d6c21682e6a3876b0de9e7be291'
+ '5f4eca9aeb0744f06d14e90d0aae74d91a1953056c27a186c793bc104c22f832')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+
+ cd "$srcdir"
+ # Configuration
+ install -Dm644 webssh.conf.d "$pkgdir/etc/conf.d/webssh"
+ install -Dm644 webssh.service \
+ "$pkgdir/usr/lib/systemd/system/webssh.service"
+ install -Dm644 sysusers.conf "$pkgdir/usr/lib/sysusers.d/webssh.conf"
+}
diff --git a/sysusers.conf b/sysusers.conf
new file mode 100644
index 000000000000..d2c0c107fbc9
--- /dev/null
+++ b/sysusers.conf
@@ -0,0 +1,2 @@
+g webssh - -
+u webssh - "webssh user" /usr/bin/nologin
diff --git a/webssh.conf.d b/webssh.conf.d
new file mode 100644
index 000000000000..ab8690c975e7
--- /dev/null
+++ b/webssh.conf.d
@@ -0,0 +1,5 @@
+#
+# Parameters to be passed to webssh
+#
+
+WEBSSH_ARGS="--address='127.0.0.1' --port=8822"
diff --git a/webssh.service b/webssh.service
new file mode 100644
index 000000000000..fb0c2abbae73
--- /dev/null
+++ b/webssh.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=SSH Web Front End
+
+[Service]
+User=webssh
+EnvironmentFile=/etc/conf.d/webssh
+ExecStart=/usr/bin/wssh $WEBSSH_ARGS
+
+[Install]
+WantedBy=multi-user.target