summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Joram2015-08-13 18:48:24 +0200
committerPhilipp Joram2015-08-13 18:48:24 +0200
commit17a09a6c10b77e444e220ef73abf7e5af142517b (patch)
treeafaca965e03f8a3fc59c6b548d19e64e1514004e
downloadaur-17a09a6c10b77e444e220ef73abf7e5af142517b.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76e11a5ee813
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-wget
+ pkgdesc = pure python download utility
+ pkgver = 2.2
+ pkgrel = 1
+ url = http://bitbucket.org/techtonik/python-wget
+ arch = any
+ license = GPL
+ depends = python
+ options = !emptydirs
+ source = https://bitbucket.org/techtonik/python-wget/get/2.2.tar.gz
+ md5sums = 47cca89b0915d13e4793067f0e634d7c
+
+pkgname = python-wget
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d3ab1f0a680
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Philipp Joram <phijor AT t-online DOT de>
+
+pkgname=python-wget
+_hgname=$pkgname
+_hgauthor=techtonik
+_hgcommit=9c0e6f40b3c7
+pkgver=2.2
+pkgrel=1
+pkgdesc="pure python download utility"
+arch=(any)
+url="http://bitbucket.org/$_hgauthor/$_hgname"
+license=('GPL')
+depends=('python')
+options=(!emptydirs)
+
+source=("https://bitbucket.org/$_hgauthor/$_hgname/get/$pkgver.tar.gz")
+md5sums=('47cca89b0915d13e4793067f0e634d7c')
+
+package() {
+ cd "$srcdir/$_hgauthor-$_hgname-$_hgcommit"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: