summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxdavidwu2020-09-19 20:27:28 +0800
committerxdavidwu2020-09-19 20:27:28 +0800
commit92ab5eacdb7b6775816893cecc2acf9df71fc8d4 (patch)
tree17e9dfe4397683fa32d6001bc11c5e939da937f5
parent90bddeb6a3610d28f35726916fdbe766554f4866 (diff)
downloadaur-92ab5eacdb7b6775816893cecc2acf9df71fc8d4.tar.gz
simplify download path, install license, provide python-wheezy
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72be2969b9e5..3d22ae29adf3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-wheezy-0.1.167
pkgdesc = A lightweight template library (0.1.167)
pkgver = 0.1.167
- pkgrel = 1
+ pkgrel = 2
url = https://pypi.python.org/pypi/wheezy.template
arch = any
license = MIT
makedepends = python-setuptools
depends = python
+ provides = python-wheezy=0.1.167
+ conflicts = python-wheezy
conflicts = python2-wheezy
- source = https://files.pythonhosted.org/packages/b1/67/7f0a14a4cc9bd949b8d22383c26fec83a00e7bd428e15c697f998e3e37ba/wheezy.template-0.1.167.tar.gz
+ source = https://files.pythonhosted.org/packages/source/w/wheezy.template/wheezy.template-0.1.167.tar.gz
sha256sums = a2ee933452f0352fb8587d79bf6fc66dbf3a14779ef7d17b9fa75e80c0003f19
pkgname = python-wheezy-0.1.167
diff --git a/PKGBUILD b/PKGBUILD
index 87627bf9cd37..d5dc8a0f8e41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,17 +17,19 @@
_pkgname=wheezy.template
pkgname=python-wheezy-0.1.167
pkgver=0.1.167
-pkgrel=1
+pkgrel=2
pkgdesc='A lightweight template library (0.1.167)'
arch=('any')
url="https://pypi.python.org/pypi/wheezy.template"
license=('MIT')
depends=('python')
makedepends=('python-setuptools') # when fallback to distutils /usr/bin/wheezy.template will be missing
+provides=("python-wheezy=${pkgver}")
conflicts=(
+ 'python-wheezy'
'python2-wheezy' # /usr/bin/wheezy.template
)
-source=('https://files.pythonhosted.org/packages/b1/67/7f0a14a4cc9bd949b8d22383c26fec83a00e7bd428e15c697f998e3e37ba/wheezy.template-0.1.167.tar.gz')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('a2ee933452f0352fb8587d79bf6fc66dbf3a14779ef7d17b9fa75e80c0003f19')
build() {
@@ -38,4 +40,5 @@ build() {
package() {
cd "$_pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}