summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIyán Méndez Veiga2020-07-08 14:49:41 +0200
committerIyán Méndez Veiga2020-07-08 14:49:41 +0200
commiteb5ed7e6963f28fbd49551f6d2e48748e7711de0 (patch)
tree7bda623fb904ad85b50c4761ef2a1f93e70dbc74
downloadaur-eb5ed7e6963f28fbd49551f6d2e48748e7711de0.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD47
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f658c27c6ec3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = python-wifiphisher-git
+ pkgdesc = Fast automated phishing attacks against WPA networks.
+ pkgver = 787.f0be783
+ pkgrel = 1
+ url = https://github.com/sophron/wifiphisher
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-httplib2
+ depends = python-scapy
+ depends = aircrack-ng
+ depends = python-pyopenssl
+ depends = python-pyric
+ depends = python-blessings
+ depends = python-pbkdf2
+ depends = python-tornado
+ depends = hostapd
+ depends = dnsmasq
+ depends = python-dbus
+ depends = python-roguehostapd-git
+ provides = wifiphisher
+ conflicts = wifiphisher
+ conflicts = wifiphisher-git
+ source = git+https://github.com/sophron/wifiphisher.git
+ sha512sums = SKIP
+
+pkgname = python-wifiphisher-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..078063aa312a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
+# Contributor: Kyle Sferrazza <kyle.sferrazza@gmail.com>
+# Contriubutor: robertfoster
+
+pkgname=python-wifiphisher-git
+_pkgname=wifiphisher
+pkgver=r787.f0be783
+pkgrel=1
+pkgdesc='Fast automated phishing attacks against WPA networks.'
+arch=('any')
+url='https://github.com/sophron/wifiphisher'
+license=('MIT')
+depends=('python'
+ 'python-httplib2'
+ 'python-scapy'
+ 'aircrack-ng'
+ 'python-pyopenssl'
+ 'python-pyric'
+ 'python-blessings'
+ 'python-pbkdf2'
+ 'python-tornado'
+ 'hostapd'
+ 'dnsmasq'
+ 'python-dbus'
+ 'python-roguehostapd-git')
+makedepends=('git' 'python-setuptools')
+provides=('wifiphisher')
+conflicts=('wifiphisher' 'wifiphisher-git')
+source=('git+https://github.com/sophron/wifiphisher.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ install -Dm 644 -t "$pkgdir/usr/share/doc/$_pkgname/" *.md
+ install -Dm 644 LICENSE.txt "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}