summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2024-06-16 17:44:09 +0800
committerUniversebenzene2024-06-16 17:44:09 +0800
commit40fca651f99b3fba08a8c763cc1f1bf6a7627c97 (patch)
tree293eeb9ed254567938d62b89ff67996c0c75ec5d
downloadaur-40fca651f99b3fba08a8c763cc1f1bf6a7627c97.tar.gz
Initial import 0.3.2
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD59
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d8765a26968
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-wiimatch
+ pkgdesc = A package for optimal "matching" N-dimentional image background
+ pkgver = 0.3.2
+ pkgrel = 1
+ url = https://wiimatch.readthedocs.io
+ arch = any
+ license = BSD-3-Clause
+ checkdepends = python-pytest
+ checkdepends = python-scipy
+ makedepends = python-setuptools-scm
+ makedepends = python-stsci_rtd_theme
+ makedepends = python-numpydoc
+ makedepends = python-numpy
+ makedepends = texlive-latexextra
+ source = https://files.pythonhosted.org/packages/source/w/wiimatch/wiimatch-0.3.2.tar.gz
+ md5sums = 1792179f66a712ef09121344666d1a80
+
+pkgname = python-wiimatch
+ depends = python>=3.7
+ depends = python-scipy
+ optdepends = python-wiimatch-doc: Documentation for wiimatch
+
+pkgname = python-wiimatch-doc
+ pkgdesc = Documentation for Python wiimatch
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e896dcd6056d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..defacb0e4f36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+
+pkgbase=python-wiimatch
+_pyname=${pkgbase#python-}
+pkgname=("python-${_pyname}" "python-${_pyname}-doc")
+pkgver=0.3.2
+pkgrel=1
+pkgdesc="A package for optimal \"matching\" N-dimentional image background"
+arch=('any')
+url="https://wiimatch.readthedocs.io"
+license=('BSD-3-Clause')
+makedepends=('python-setuptools-scm'
+# 'python-wheel'
+# 'python-build'
+# 'python-installer'
+ 'python-stsci_rtd_theme'
+ 'python-numpydoc'
+ 'python-numpy'
+ 'texlive-latexextra') # latex.fmt: -latex; anyfontsize.sty: latexextra
+checkdepends=('python-pytest'
+ 'python-scipy')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('1792179f66a712ef09121344666d1a80')
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+ python setup.py build
+# python -m build --wheel --no-isolation
+
+ msg "Building Docs"
+ PYTHONPATH="../build/lib" make -C docs html
+}
+
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ pytest || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
+}
+
+package_python-wiimatch() {
+ depends=('python>=3.7'
+ 'python-scipy')
+ optdepends=('python-wiimatch-doc: Documentation for wiimatch')
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ install -D -m644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+# python -m installer --destdir="${pkgdir}" dist/*.whl
+}
+
+package_python-wiimatch-doc() {
+ pkgdesc="Documentation for Python wiimatch"
+ cd ${srcdir}/${_pyname}-${pkgver}/docs/_build
+
+ install -D -m644 ../../LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
+}