summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2017-01-07 13:41:12 +1100
committerMatthew Gamble2017-01-07 13:41:12 +1100
commit271ba41c52d683f1de873aeda02ede870e9997f3 (patch)
tree2794f2c07285c32f717f91593d905cc3d204f21d
parent690bbd87295dac81ec182a03927d1c03c7ccaec9 (diff)
downloadaur-271ba41c52d683f1de873aeda02ede870e9997f3.tar.gz
Update for python3.6
- Bump pkgrel for python3.6 rebuild - Fix code style - Add --optimize=1 flag
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 944966ec9a59..83827b6209bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat Jan 7 02:40:03 UTC 2017
pkgbase = python-wire
pkgdesc = A convenience wrapper around the built-in SQLite3 module in python
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/djmattyg007/python-wire
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 48e807ebb06d..c4d99c1b342e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
-# Maintainer: Matthew Gamble
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
pkgname=python-wire
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A convenience wrapper around the built-in SQLite3 module in python"
-arch=('any')
-url='https://github.com/djmattyg007/python-wire'
-license=('GPL3')
-depends=('python')
-makedepends=('python-setuptools')
+arch=("any")
+url="https://github.com/djmattyg007/python-wire"
+license=("GPL3")
+depends=("python")
+makedepends=("python-setuptools")
source=("https://github.com/djmattyg007/python-wire/archive/${pkgver}.zip")
-sha256sums=('0aaf5e3c280756fd723bf1b0fd68430da6f228d4b21a7eb9f9b18c33660bf978')
+sha256sums=("0aaf5e3c280756fd723bf1b0fd68430da6f228d4b21a7eb9f9b18c33660bf978")
package() {
cd "python-wire-$pkgver"
- python setup.py install --root="$pkgdir"
+ python setup.py install --root="$pkgdir" --optimize=1
}