summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2015-10-25 17:55:00 +1100
committerMatthew Gamble2015-10-25 17:55:00 +1100
commit690bbd87295dac81ec182a03927d1c03c7ccaec9 (patch)
tree63af12517fd0912613b8c5e5e4d9469ab662bdaf
downloadaur-690bbd87295dac81ec182a03927d1c03c7ccaec9.tar.gz
Initial commit for v1.0.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..944966ec9a59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-wire
+ pkgdesc = A convenience wrapper around the built-in SQLite3 module in python
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/djmattyg007/python-wire
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/djmattyg007/python-wire/archive/1.0.0.zip
+ sha256sums = 0aaf5e3c280756fd723bf1b0fd68430da6f228d4b21a7eb9f9b18c33660bf978
+
+pkgname = python-wire
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48e807ebb06d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Matthew Gamble
+
+pkgname=python-wire
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A convenience wrapper around the built-in SQLite3 module in python"
+arch=('any')
+url='https://github.com/djmattyg007/python-wire'
+license=('GPL3')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://github.com/djmattyg007/python-wire/archive/${pkgver}.zip")
+sha256sums=('0aaf5e3c280756fd723bf1b0fd68430da6f228d4b21a7eb9f9b18c33660bf978')
+
+package() {
+ cd "python-wire-$pkgver"
+ python setup.py install --root="$pkgdir"
+}