summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLara Maia2015-06-12 00:36:09 -0300
committerLara Maia2015-06-12 00:36:09 -0300
commit3717daa1f20ee024c092653d0033c55e1124b0d7 (patch)
tree52138b7f01d5880ca712f4b77255e405beca37ec
downloadaur-3717daa1f20ee024c092653d0033c55e1124b0d7.tar.gz
Initial import
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
3 files changed, 64 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..c8cc4b3d1e01
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,18 @@
+pkgbase = python-wiringpi2-git
+ pkgdesc = Python-wrapped version of Gordon Henderson's WiringPI version 2.
+ pkgver = 20140604
+ pkgrel = 1
+ url = https://github.com/WiringPi/WiringPi2-Python
+ arch = x86_64
+ arch = i686
+ arch = armv6h
+ license = GPLv3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ provides = python-wiringpi2
+ conflicts = python-wiringpi2
+ source = git+https://github.com/WiringPi/WiringPi2-Python.git
+
+pkgname = python-wiringpi2-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57e9e0389e15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-wiringpi2-git
+ pkgdesc = Python-wrapped version of Gordon Henderson's WiringPI version 2.
+ pkgver = 20140604
+ pkgrel = 1
+ url = https://github.com/WiringPi/WiringPi2-Python
+ arch = x86_64
+ arch = i686
+ arch = armv6h
+ license = GPLv3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ provides = python-wiringpi2
+ conflicts = python-wiringpi2
+ source = git+https://github.com/WiringPi/WiringPi2-Python.git
+ md5sums = SKIP
+
+pkgname = python-wiringpi2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc94033d3cea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Lara Maia <lara@craft.net.br>
+pkgname=python-wiringpi2-git
+pkgver=20140604
+pkgrel=1
+pkgdesc="Python-wrapped version of Gordon Henderson's WiringPI version 2."
+url="https://github.com/WiringPi/WiringPi2-Python"
+arch=('x86_64' 'i686' 'armv6h')
+license=('GPLv3')
+depends=('python')
+makedepends=('git' 'python-setuptools')
+conflicts=('python-wiringpi2')
+provides=('python-wiringpi2')
+source=(git+https://github.com/WiringPi/WiringPi2-Python.git)
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir"/WiringPi2-Python
+
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/WiringPi2-Python
+
+ python setup.py install --prefix=/usr --root=$pkgdir
+}
+