summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-06-28 23:18:53 +0300
committerIgor Dyatlov2022-06-28 23:18:53 +0300
commit4e6fde08137da78a1310e4652aa1db90f1229fec (patch)
treeb4f131b51d91273999cd0239250d625ce4d16604
parentd04b02025c3248bc4b17bf194b7e0a28a8a23d86 (diff)
downloadaur-4e6fde08137da78a1310e4652aa1db90f1229fec.tar.gz
Updates
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
-rw-r--r--setup.py32
3 files changed, 47 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 544f66f9544f..674793cccfed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = python-wn
pkgdesc = Stand-alone WordNet API
- pkgver = 0.8.0
+ pkgver = 0.9.1
pkgrel = 1
url = https://github.com/goodmami/wn
arch = any
license = MIT
makedepends = python-setuptools
- depends = python
depends = python-importlib_resources
depends = python-requests
depends = python-toml
- source = wn-v0.8.0.tar.gz::https://files.pythonhosted.org/packages/1b/8e/43630bec3f2e75f8c95cdd8f744091e0baee52680c86eb9332f9113b5b1a/wn-0.8.0.tar.gz
- b2sums = 35e21bb9501b08f8f854eb6efa8917b46b228216fa47852f180589017b28ce5e28636c0dfe11082369bdcc5d90b60852e54aa354cb668da0a1a125a23ff86d06
+ source = wn-v0.9.1.tar.gz::https://files.pythonhosted.org/packages/50/5e/9ffb97e96d1f1ca421a2c5b218ddc2e5ec145a2441d350e98ad58fa6dad0/wn-0.9.1.tar.gz
+ source = setup.py
+ b2sums = 525cd5513f4f46250e78b3295ba2cc57f9d96c7d953128bec061844e979108cab73e9dec4e22c90568f6d0be23c48cf888af8b3c9fbc6e050978a398c376b1f9
+ b2sums = 23629d56e738eab2fd44099db1a07fa86ea69694169981d60e73feb6de4a4ec735617f4610da91e1980e8e69d075e1448e5611fa382908b62d7f778ead1ae1d8
pkgname = python-wn
diff --git a/PKGBUILD b/PKGBUILD
index 89a00a82a2f9..aa99ae2f9349 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,22 +5,23 @@
pkgname=python-wn
_author=goodmami
_gitname=wn
-pkgver=0.8.0
+pkgver=0.9.1
pkgrel=1
pkgdesc="Stand-alone WordNet API"
arch=('any')
url='https://github.com/goodmami/wn'
license=('MIT')
-depends=(
- python
- python-importlib_resources
- python-requests
- python-toml
-)
+depends=('python-importlib_resources' 'python-requests' 'python-toml')
makedepends=('python-setuptools')
-source=("$_gitname-v$pkgver.tar.gz::https://files.pythonhosted.org/packages/1b/8e/43630bec3f2e75f8c95cdd8f744091e0baee52680c86eb9332f9113b5b1a/${_gitname}-${pkgver}.tar.gz")
-b2sums=('35e21bb9501b08f8f854eb6efa8917b46b228216fa47852f180589017b28ce5e28636c0dfe11082369bdcc5d90b60852e54aa354cb668da0a1a125a23ff86d06')
+source=("$_gitname-v$pkgver.tar.gz::https://files.pythonhosted.org/packages/50/5e/9ffb97e96d1f1ca421a2c5b218ddc2e5ec145a2441d350e98ad58fa6dad0/${_gitname}-${pkgver}.tar.gz"
+ setup.py)
+b2sums=('525cd5513f4f46250e78b3295ba2cc57f9d96c7d953128bec061844e979108cab73e9dec4e22c90568f6d0be23c48cf888af8b3c9fbc6e050978a398c376b1f9'
+ '23629d56e738eab2fd44099db1a07fa86ea69694169981d60e73feb6de4a4ec735617f4610da91e1980e8e69d075e1448e5611fa382908b62d7f778ead1ae1d8')
+prepare() {
+ mv setup.py $_gitname-$pkgver/setup.py
+}
+
build() {
cd $_gitname-$pkgver
python setup.py build
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..cb2295f4bfc9
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,32 @@
+#!/usr/bin/env python
+# setup.py generated by flit for tools that don't yet use PEP 517
+
+from distutils.core import setup
+
+packages = \
+['wn']
+
+package_data = \
+{'': ['*']}
+
+install_requires = \
+['requests~=2.25', 'toml~=0.10']
+
+extras_require = \
+{":python_version < '3.7'": ['importlib_resources'],
+ 'doc': ['sphinx>=3.5,<4', 'furo', 'sphinx-copybutton'],
+ 'test': ['pytest', 'mypy', 'flake8', 'nox', 'types-requests', 'types-toml'],
+ 'web': ['starlette']}
+
+setup(name='wn',
+ version='0.9.1',
+ description='Wordnet Interface.',
+ author='Michael Wayne Goodman',
+ author_email='goodman.m.w@gmail.com',
+ url='https://github.com/goodmami/wn',
+ packages=packages,
+ package_data=package_data,
+ install_requires=install_requires,
+ extras_require=extras_require,
+ python_requires='>=3.6',
+ )