summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Cassani2019-06-06 11:52:41 +0200
committerFederico Cassani2019-06-06 11:52:41 +0200
commit8ce157b49dfc4c3d5c771bd89985a2c9322e31ba (patch)
tree358b108e5be931ef1fcb491ed6ce518a7947637d
downloadaur-8ce157b49dfc4c3d5c771bd89985a2c9322e31ba.tar.gz
INIT version 0.0.19
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD26
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1345d0fd7f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-wn
+ pkgdesc = Stand-alone WordNet API
+ pkgver = 0.0.19
+ pkgrel = 1
+ url = https://github.com/alvations/wordnet
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/34/cc/45d03eb6defd1e96a3e35edd6032818f0318b2b4ff2f3cfffa3b675f1722/wn-0.0.19.tar.gz
+ sha256sums = 72f8259487a09d7716bce02cc4f1f1c79e9c102b5d2c4a0bc5e935e55ce71f59
+
+pkgname = python-wn
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f6b4a8512010
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35245309afcc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Federico Cassani <federico dot cassani at outlook dot com>
+
+pkgname=python-wn
+_pkgname=wn
+pkgver=0.0.19
+pkgrel=1
+pkgdesc="Stand-alone WordNet API"
+arch=('any')
+url='https://github.com/alvations/wordnet'
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/34/cc/45d03eb6defd1e96a3e35edd6032818f0318b2b4ff2f3cfffa3b675f1722/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('72f8259487a09d7716bce02cc4f1f1c79e9c102b5d2c4a0bc5e935e55ce71f59')
+
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py build
+}
+
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+