summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2016-12-29 16:28:35 +0100
committerEmmanuel Gil Peyrot2016-12-29 16:28:48 +0100
commit1a7ec60559ee73c578342d14e80d88e04ffd1aef (patch)
tree9a9b6e7312c9d7e611057b57e6be8440bd41db02
downloadaur-1a7ec60559ee73c578342d14e80d88e04ffd1aef.tar.gz
Initial commit.
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD44
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af3278ed1d39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Thu Dec 29 15:27:07 UTC 2016
+pkgbase = python-wokkel-git
+ pkgdesc = Twisted Jabber support library - git version
+ pkgver = 0.7.1.r45.g9df5060
+ pkgrel = 1
+ url = http://wokkel.ik.nu/
+ arch = any
+ license = custom:"Wokkel License"
+ makedepends = git
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = git+https://github.com/ralphm/wokkel
+ md5sums = SKIP
+
+pkgname = python-wokkel-git
+ depends = python-twisted
+ provides = python-wokkel=0.8
+ conflicts = python-wokkel
+ conflicts = python-wokkel-hg
+ replaces = python-wokkel-hg
+
+pkgname = python2-wokkel-git
+ depends = python2-twisted
+ provides = python2-wokkel=0.8
+ conflicts = python2-wokkel
+ conflicts = python2-wokkel-hg
+ replaces = python2-wokkel-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25fab758795c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Maurizio Porrato <maurizio.porrato@gmail.com>
+
+_realname=wokkel
+pkgbase=python-wokkel-git
+pkgname=('python-wokkel-git' 'python2-wokkel-git')
+pkgver=0.7.1.r45.g9df5060
+pkgrel=1
+pkgdesc="Twisted Jabber support library - git version"
+license=('custom:"Wokkel License"')
+url="http://wokkel.ik.nu/"
+source=("git+https://github.com/ralphm/wokkel")
+arch=(any)
+makedepends=('git' 'python-setuptools' 'python2-setuptools')
+
+pkgver() {
+ cd "$srcdir/$_realname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package_python-wokkel-git() {
+ depends=('python-twisted')
+ conflicts=('python-wokkel' 'python-wokkel-hg')
+ replaces=('python-wokkel-hg')
+ provides=('python-wokkel=0.8')
+
+ cd "$srcdir/$_realname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_python2-wokkel-git() {
+ depends=('python2-twisted')
+ conflicts=('python2-wokkel' 'python2-wokkel-hg')
+ replaces=('python2-wokkel-hg')
+ provides=('python2-wokkel=0.8')
+
+ cd "$srcdir/$_realname"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+md5sums=('SKIP')