summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpeippo2020-02-26 12:42:27 +0000
committerpeippo2020-02-26 12:42:27 +0000
commit8879aabbf12ba409f7385e4437610bbab7133c12 (patch)
treea71ccbe10d3c1933da210e0623badaa44bca3282
downloadaur-8879aabbf12ba409f7385e4437610bbab7133c12.tar.gz
python-wolkenbruch-0.2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..35f07e7e21d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-wolkenbruch
+ pkgdesc = Remind you to pack your rain gear when it’s forecast to rain
+ pkgver = 0.2
+ pkgrel = 0
+ url = https://gitlab.com/christophfink/wolkenbruch/
+ arch = x86_64
+ arch = i686
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-requests
+ depends = python-geocoder
+ source = https://files.pythonhosted.org/packages/source/w/wolkenbruch/wolkenbruch-0.2.tar.gz
+ sha256sums = 1e8cc7316e239976ef44cab6f5c6e24c090b0e7867cec044480b8581f1623895
+
+pkgname = python-wolkenbruch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a80e3216d966
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: peippo <christoph.fink@gmail.com>
+
+pkgname=python-wolkenbruch
+_name="${pkgname#python-}"
+pkgdesc="Remind you to pack your rain gear when it’s forecast to rain"
+url="https://gitlab.com/christophfink/wolkenbruch/"
+
+pkgver=0.2
+pkgrel=0
+
+arch=("x86_64" "i686")
+license=("BSD")
+
+makedepends=(
+ "python-setuptools"
+)
+depends=(
+ "python"
+ "python-requests"
+ "python-geocoder"
+)
+
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=("1e8cc7316e239976ef44cab6f5c6e24c090b0e7867cec044480b8581f1623895")
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ # install systemd service + timer
+ install -Dm644 \
+ "extra/systemd/wolkenbruch@."{timer,service} \
+ -t "${pkgdir}/usr/lib/systemd/system/"
+
+ install -Dm644 \
+ LICENSE \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}