summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Diza2022-05-05 16:35:15 -0700
committerJoseph Diza2022-05-05 16:35:15 -0700
commit0b2c312dbcb880ec0e0ac865fa8289aa1003cdf8 (patch)
tree9dd3b6453eba2d91363d4c880a9946935a658679
downloadaur-0b2c312dbcb880ec0e0ac865fa8289aa1003cdf8.tar.gz
Initial commit of python-wora-git package
-rw-r--r--.SRCINFO15
l---------Makefile1
-rw-r--r--PKGBUILD26
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44faaeb09cfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-wora-git
+ pkgdesc = Write once run anywhere, a python library with general purpose utilities.
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = https://github.com/jmdaemon/wora
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python-toml
+ provides = python-wora
+ conflicts = python-wora
+ source = python-wora-git::git+https://github.com/jmdaemon/wora#branch=master
+ sha512sums = SKIP
+
+pkgname = python-wora-git
diff --git a/Makefile b/Makefile
new file mode 120000
index 000000000000..d0b0e8e0086f
--- /dev/null
+++ b/Makefile
@@ -0,0 +1 @@
+../Makefile \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32884fcef711
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Joseph Diza <josephm.diza@gmail.com
+
+pkgname=python-wora-git
+pkgver=0.1.6
+pkgrel=1
+arch=('any')
+pkgdesc='Write once run anywhere, a python library with general purpose utilities.'
+url='https://github.com/jmdaemon/wora'
+license=('GPL')
+depends=('python-toml')
+optdepends=()
+makedepends=('python-setuptools')
+source=("$pkgname::git+https://github.com/jmdaemon/wora#branch=master")
+provides=(python-wora)
+conflicts=(python-wora)
+sha512sums=("SKIP")
+
+build() {
+ cd "$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root "$pkgdir" --optimize=1
+}