summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBet42020-09-19 08:55:33 +0800
committerBet42020-09-19 08:55:33 +0800
commit59a7d0b29078babf0e48c41137a46b01eae5df78 (patch)
treeaeb022598ce5ba2ef3c6fa8a0c89a4a2f391da41
parent6b8c82f26304c3f557aec80106ab11da16d86b15 (diff)
downloadaur-59a7d0b29078babf0e48c41137a46b01eae5df78.tar.gz
Update to latest git version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cceac1394512..ea777bc5e49c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-word_forms-git
pkgdesc = Accurately generate all possible forms of an English word
- pkgver = r29.4e1d76f
+ pkgver = 2.1.0.r1.g9f24160
pkgrel = 1
url = https://github.com/gutfeeling/word_forms
arch = any
@@ -8,7 +8,7 @@ pkgbase = python-word_forms-git
makedepends = python-setuptools
depends = python-nltk
depends = python-inflect
- depends = python-unipath
+ depends = python-levenshtein
source = git+https://github.com/gutfeeling/word_forms.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b14e30f3b900..04a7dba110e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
_pkgname=word_forms
pkgname=python-$_pkgname-git
-pkgver=r29.4e1d76f
+pkgver=2.1.0.r1.g9f24160
pkgrel=1
pkgdesc="Accurately generate all possible forms of an English word"
arch=('any')
url="https://github.com/gutfeeling/word_forms"
license=('MIT')
-depends=('python-nltk' 'python-inflect' 'python-unipath')
+depends=('python-nltk' 'python-inflect' 'python-levenshtein')
makedepends=('python-setuptools')
source=("git+${url}.git")
sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {