summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Veness2016-12-04 18:58:46 -0800
committerTyler Veness2016-12-18 18:13:37 -0800
commitd80b9d140caa2d96b540f5d1239a5e962f532ee9 (patch)
treee7288772bcef852cf1c238b0b3079b5658c4ea5a
downloadaur-d80b9d140caa2d96b540f5d1239a5e962f532ee9.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..976be5293e20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-wpiformat-git
+ pkgdesc = Linters and formatters for ensuring WPILib\'s source code conforms to its style guide
+ pkgver = 2016.47
+ pkgrel = 1
+ url = http://github.com/wpilibsuite/styleguide
+ arch = i686
+ arch = x86_64
+ license = custom=FRC-BSD
+ checkdepends = python-pytest-runner
+ checkdepends = python-pip
+ checkdepends = git
+ makedepends = git
+ depends = clang
+ depends = yapf
+ provides = python-wpiformat
+ conflicts = python-wpiformat
+ source = git+git://github.com/wpilibsuite/styleguide
+ md5sums = SKIP
+
+pkgname = python-wpiformat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..153ba7684993
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Tyler Veness <calcmogul at gmail dot com>
+
+pkgname=python-wpiformat-git
+_gitname=styleguide
+pkgver=2016.47
+pkgrel=1
+pkgdesc="Linters and formatters for ensuring WPILib\'s source code conforms to its style guide"
+arch=('i686' 'x86_64')
+url="http://github.com/wpilibsuite/styleguide"
+license=('custom=FRC-BSD')
+depends=('clang' 'yapf')
+makedepends=('git')
+checkdepends=('python-pytest-runner' 'python-pip' 'git')
+provides=('python-wpiformat')
+conflicts=('python-wpiformat')
+source=(git+git://github.com/wpilibsuite/styleguide)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ year=$(date +%Y)
+ echo $year.$(git rev-list --count --after="master@{$year-01-01}" master)
+}
+
+build() {
+ cd "$srcdir/$_gitname/wpiformat"
+ python setup.py build
+}
+
+check() {
+ cd "$srcdir/$_gitname/wpiformat"
+ python setup.py test
+}
+
+package() {
+ cd "$srcdir/$_gitname/wpiformat"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+}
+
+# vim:set ts=2 sw=2 et: