summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuval Adam2015-06-30 15:52:03 +0300
committerYuval Adam2015-06-30 15:52:03 +0300
commit071ded7fe1351ca09127092313d18977406a6a30 (patch)
tree40422cbdea639d7f12beffe58e3d208b3bbd5b3c
downloadaur-071ded7fe1351ca09127092313d18977406a6a30.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8db57c6ea73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-wpull
+ pkgdesc = Wget-compatible web downloader and crawler
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/chfoo/wpull
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ source = http://pypi.python.org/packages/source/w/wpull/wpull-1.2.1.tar.gz
+ sha256sums = c2491df6dd51548e598f4551032f5c8fde57006fed035832cdf9a19e732d2a9c
+
+pkgname = python-wpull
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e72811af88a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Yuval Adam <yuval at y3xz dot com> PGP-Key: 271386AA2EB7672F
+
+pkgname=python-wpull
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Wget-compatible web downloader and crawler"
+arch=('any')
+url="https://github.com/chfoo/wpull"
+license=(GPL)
+depends=('python')
+makedepends=('python-setuptools')
+source=("http://pypi.python.org/packages/source/w/wpull/wpull-${pkgver}.tar.gz")
+sha256sums=('c2491df6dd51548e598f4551032f5c8fde57006fed035832cdf9a19e732d2a9c')
+
+package() {
+ cd "${srcdir}/wpull-${pkgver}"
+ python setup.py install --prefix=/usr --root="$pkgdir/"
+}
+
+# vim:set ts=2 sw=2 et: