summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Cassani2019-06-06 11:59:42 +0200
committerFederico Cassani2019-06-06 11:59:42 +0200
commit39528650976921a38313a271b4bf900c04795129 (patch)
treea02a81881f0f2eca3176092e7506269f876fe6e2
downloadaur-39528650976921a38313a271b4bf900c04795129.tar.gz
INIT version 0.6.4
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD24
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e1058332962
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-wrangle
+ pkgdesc = Wrangle takes the headache away from most common data preparation and wrangling tasks.
+ pkgver = 0.6.4
+ pkgrel = 1
+ url = https://github.com/autonomio/wrangle/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-keras
+ depends = python-statsmodels
+ depends = python-scikit-learn
+ depends = python-numpy
+ depends = python-pandas
+ depends = python-scipy
+ source = https://files.pythonhosted.org/packages/17/9d/43d42e8bb95ef067635494fa8a0219a97d100c7ff96fb825ac01b72670b9/wrangle-0.6.4.tar.gz
+ sha256sums = 7dd1e71a3e8ed4285385c82863dcbb5f47da134500ddbd3b32cc8cb8a4e53033
+
+pkgname = python-wrangle
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f6b4a8512010
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d7cc0af1d3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Federico Cassani <federico dot cassani at outlook dot com>
+
+pkgname="python-wrangle"
+_pkgname="wrangle"
+pkgver=0.6.4
+pkgrel=1
+pkgdesc="Wrangle takes the headache away from most common data preparation and wrangling tasks."
+arch=('any')
+url="https://github.com/autonomio/wrangle/"
+license=('MIT')
+depends=('python' 'python-keras' 'python-statsmodels' 'python-scikit-learn' 'python-numpy' 'python-pandas' 'python-scipy')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/17/9d/43d42e8bb95ef067635494fa8a0219a97d100c7ff96fb825ac01b72670b9/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('7dd1e71a3e8ed4285385c82863dcbb5f47da134500ddbd3b32cc8cb8a4e53033')
+
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}