summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcoxackie2020-12-06 09:04:26 +0000
committercoxackie2020-12-06 09:04:26 +0000
commitf78344a7a1a3fb12494073d1d43d4c5861c1661a (patch)
tree2dc86bc404e3963052739ce7eac307c8df8e17d3
downloadaur-f78344a7a1a3fb12494073d1d43d4c5861c1661a.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cefc80af7a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-wrapio
+ pkgdesc = Handling event-based streams.
+ pkgver = 0.3.8
+ pkgrel = 1
+ url = https://github.com/Exahilosys/wrapio
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = python>=3.5
+ provides = python-wrapio
+ source = https://github.com/Exahilosys/wrapio/archive/v0.3.8.tar.gz
+ md5sums = 170de19707eaa0596db01b0edac405d0
+
+pkgname = python-wrapio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..324a7bd8beb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Kostas Kardaras <firstname dot lastname at gmail>
+
+_pkgname='wrapio'
+pkgname='python-wrapio'
+provides=('python-wrapio')
+conflicts=()
+pkgver=0.3.8
+pkgrel=1
+pkgdesc='Handling event-based streams.'
+arch=('x86_64')
+url="https://github.com/Exahilosys/${_pkgname}"
+license=('MIT')
+source=("${url}/archive/v${pkgver}.tar.gz")
+makedepends=('python-setuptools')
+depends=(
+ 'python>=3.5')
+optdepends=()
+md5sums=('170de19707eaa0596db01b0edac405d0')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ # Run python setup function
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ # Install the licence
+ install -Dm644 "${srcdir}/${_pkgname}-${pkgver}/LICENCE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}