summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Pereira2023-05-08 13:47:56 +0100
committerGonçalo Pereira2023-05-08 13:47:56 +0100
commitab628b7fc1ef1ab4c8c000047a2c739448f2974e (patch)
tree59aff0e8633a9cc5b8da8bd343734ded102ff7e0
downloadaur-ab628b7fc1ef1ab4c8c000047a2c739448f2974e.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef15c57a348a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-wrapt-timeout-decorator
+ pkgdesc = Powerful Timeout Decorator that can be used safely on classes, methods, class methods
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/bitranox/wrapt_timeout_decorator
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-cli_exit_tools
+ depends = python-python-lib-detect-testenv
+ depends = python-multiprocess
+ depends = python-psutil
+ depends = python-wrapt
+ source = https://files.pythonhosted.org/packages/source/w/wrapt-timeout-decorator/wrapt-timeout-decorator-1.0.1.tar.gz
+ sha256sums = 0b0f1a0d608c51f24cbcba3fd93226ae84029450328957be4245530177a610c9
+
+pkgname = python-wrapt-timeout-decorator
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c075a991d6b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Gonçalo Pereira <goncalo_pereira@outlook.pt>
+pkgname=python-wrapt-timeout-decorator
+_name=${pkgname#python-}
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Powerful Timeout Decorator that can be used safely on classes, methods, class methods"
+url="https://github.com/bitranox/wrapt_timeout_decorator"
+depends=(
+ 'python'
+ 'python-cli_exit_tools'
+ 'python-python-lib-detect-testenv'
+ 'python-multiprocess'
+ 'python-psutil'
+ 'python-wrapt'
+)
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('0b0f1a0d608c51f24cbcba3fd93226ae84029450328957be4245530177a610c9')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}