summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2017-07-01 13:14:25 +0200
committerValHue2017-07-01 13:14:25 +0200
commit0a632f4bf7e1712a19a452d34d64c3790c58948d (patch)
tree2ea47ce6cf9c8511d26e675e2d444426f4de7177
parentc445fdca72069320347efd2a2b2e62f9163d54f9 (diff)
downloadaur-0a632f4bf7e1712a19a452d34d64c3790c58948d.tar.gz
Update to 0.4.2-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD32
2 files changed, 23 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 780a4211fa73..333210b14d72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python-ws4py
pkgdesc = WebSocket client and server library for Python.
- pkgver = 0.3.4
+ pkgver = 0.4.2
pkgrel = 1
- url = https://pypi.python.org/pypi/ws4py
+ url = https://github.com/Lawouach/WebSocket-for-Python
arch = any
license = BSD
makedepends = python-setuptools
depends = python
- source = https://pypi.python.org/packages/source/w/ws4py/ws4py-0.3.4.tar.gz
- md5sums = 6b47e33cbd13f5c134b04f2a44a480ad
+ provides = ws4py
+ source = ws4py-0.4.2.tar.gz::https://github.com/Lawouach/WebSocket-for-Python/archive/0.4.2.tar.gz
+ sha256sums = eb47a057863ec789611091c22480f0333e746fe01ce3df34525ab0c12d52bc2b
pkgname = python-ws4py
diff --git a/PKGBUILD b/PKGBUILD
index 600c22c9a6e1..45eb0643fb6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
-# Maintainer: korjjj <korjjj+aur[at]gmail[dot]com>
-
-pkgname=python-ws4py
-_pkgname=ws4py
-pkgver=0.3.4
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# https://github.com/ValHue/AUR-PKGBUILDs
+#
+# Contributor: korjjj <korjjj+aur[at]gmail[dot]com>
+#
+_pkgname="ws4py"
+pkgname="python-${_pkgname}"
+pkgver=0.4.2
pkgrel=1
-pkgdesc='WebSocket client and server library for Python.'
-arch=('any')
-url='https://pypi.python.org/pypi/ws4py'
+pkgdesc="WebSocket client and server library for Python."
+url="https://github.com/Lawouach/WebSocket-for-Python"
license=('BSD')
-makedepends=('python-setuptools')
+arch=('any')
depends=('python')
-source=("https://pypi.python.org/packages/source/w/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-md5sums=('6b47e33cbd13f5c134b04f2a44a480ad')
+makedepends=('python-setuptools')
+provides=("${_pkgname}")
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/Lawouach/WebSocket-for-Python/archive/${pkgver}.tar.gz")
+sha256sums=('eb47a057863ec789611091c22480f0333e746fe01ce3df34525ab0c12d52bc2b')
package() {
- cd $srcdir/${_pkgname}-${pkgver}
- python setup.py install --root=${pkgdir} --optimize=1
+ cd "${srcdir}/WebSocket-for-Python-${pkgver}"
+ python setup.py install --root=${pkgdir} --optimize=1
}
-# vim:set ts=2 sw=2 et:
+# vim:set ts=4 sw=2 ft=sh et: