summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2020-10-12 19:06:50 +1100
committerMatthew Gamble2020-10-12 19:06:50 +1100
commit25b8e8b456cc211ff6946d06e2a95084c33136f6 (patch)
tree122cc4a5a4e7486c638ae35cf04a21c1dde69f8a
parenta4e85015ef3b9955f6e14788e37ad9d91f82b088 (diff)
downloadaur-25b8e8b456cc211ff6946d06e2a95084c33136f6.tar.gz
Update to latest release
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD21
-rw-r--r--config.example.json4
-rw-r--r--config.example.json513
5 files changed, 40 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2ad200eb8cc..632c88a620ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-wsgidav
pkgdesc = Generic WebDAV server based on WSGI
- pkgver = 3.0.1
- pkgrel = 3
+ pkgver = 3.0.3
+ pkgrel = 1
url = https://github.com/mar10/wsgidav
arch = any
license = MIT
@@ -10,20 +10,23 @@ pkgbase = python-wsgidav
depends = python-defusedxml
depends = python-setuptools
depends = python-yaml
- depends = python-jsmin
+ depends = python-json5
depends = python-jinja
+ depends = python-six
optdepends = python-lxml: for faster XML processing
optdepends = python-cheroot: to use the built-in webserver
- source = https://files.pythonhosted.org/packages/17/c4/360564dac7ad8f0a13914436b011dc520e898608cd80179b074ad6a27a0c/WsgiDAV-3.0.1.tar.gz
- source = https://raw.githubusercontent.com/mar10/wsgidav/v3.0.1/LICENSE
+ source = https://files.pythonhosted.org/packages/ac/e1/4885f4d8f5b4275be418ebb1b1c76323304799f9c8bd40deeeba23787a29/WsgiDAV-3.0.3.tar.gz
+ source = LICENSE-v3.0.3::https://raw.githubusercontent.com/mar10/wsgidav/v3.0.3/LICENSE
source = uwsgi.py
source = uwsgi.ini
source = config.example.json
- sha256sums = 415ac221806a266a3661f6f2f91ecc8dbcbe3653cdb1508abc0c397ea0cf35f3
- sha256sums = a95c307807f8f5b404301b593b26b41d387982120f5683187c24247084081127
+ source = config.example.json5
+ sha256sums = bb1b8ded03daac0638e65385a805ae208d11afe07a1014cee746139fc6ffaad6
+ sha256sums = 488580937d6e2549a12454861c17b5106c0a62761f2f052ce2453097abbd841f
sha256sums = 774ee839b5248d2614294daf2c8a28fda69f1524d8b5b61d9e75de7b9c986b4d
sha256sums = 25826e3ceec2e9e01c54e6367966537017b0c758c7eda131566a95f97b474250
- sha256sums = 17bd5af150b9f8666cac503c6c46e671263f143e59b04dfb3033a0752f7bf6a5
+ sha256sums = 9e4d7e9ae9e56a5d0f14c91b296825114e57456888280e59dcf158dad36b9474
+ sha256sums = 28ee019fad42e9c7a2611147defec5e3bb6d2fbb3f5f69390a066f1c1033ef16
pkgname = python-wsgidav
diff --git a/.gitignore b/.gitignore
index e807e1d1cbe7..663888123d68 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
/pkg/
/src/
/LICENSE
-*.pkg.tar.xz
+/LICENSE-v*
+*.pkg.tar.*
*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index b1ab609da532..ab4bd28b6985 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
# Maintainer: Matthew Gamble <git@matthewgamble.net>
pkgname=python-wsgidav
-pkgver=3.0.1
-pkgrel=3
+pkgver=3.0.3
+pkgrel=1
pkgdesc="Generic WebDAV server based on WSGI"
arch=("any")
license=("MIT")
url="https://github.com/mar10/wsgidav"
-depends=("python" "python-defusedxml" "python-setuptools" "python-yaml" "python-jsmin" "python-jinja")
+depends=("python" "python-defusedxml" "python-setuptools" "python-yaml" "python-json5" "python-jinja" "python-six")
makedepends=("python-setuptools")
optdepends=(
"python-lxml: for faster XML processing"
"python-cheroot: to use the built-in webserver"
)
source=(
- "https://files.pythonhosted.org/packages/17/c4/360564dac7ad8f0a13914436b011dc520e898608cd80179b074ad6a27a0c/WsgiDAV-3.0.1.tar.gz"
- "https://raw.githubusercontent.com/mar10/wsgidav/v${pkgver}/LICENSE"
+ "https://files.pythonhosted.org/packages/ac/e1/4885f4d8f5b4275be418ebb1b1c76323304799f9c8bd40deeeba23787a29/WsgiDAV-3.0.3.tar.gz"
+ "LICENSE-v${pkgver}::https://raw.githubusercontent.com/mar10/wsgidav/v${pkgver}/LICENSE"
"uwsgi.py"
"uwsgi.ini"
"config.example.json"
+ "config.example.json5"
)
sha256sums=(
- "415ac221806a266a3661f6f2f91ecc8dbcbe3653cdb1508abc0c397ea0cf35f3"
- "a95c307807f8f5b404301b593b26b41d387982120f5683187c24247084081127"
+ "bb1b8ded03daac0638e65385a805ae208d11afe07a1014cee746139fc6ffaad6"
+ "488580937d6e2549a12454861c17b5106c0a62761f2f052ce2453097abbd841f"
"774ee839b5248d2614294daf2c8a28fda69f1524d8b5b61d9e75de7b9c986b4d"
"25826e3ceec2e9e01c54e6367966537017b0c758c7eda131566a95f97b474250"
- "17bd5af150b9f8666cac503c6c46e671263f143e59b04dfb3033a0752f7bf6a5"
+ "9e4d7e9ae9e56a5d0f14c91b296825114e57456888280e59dcf158dad36b9474"
+ "28ee019fad42e9c7a2611147defec5e3bb6d2fbb3f5f69390a066f1c1033ef16"
)
build() {
@@ -37,8 +39,9 @@ package() {
cd "WsgiDAV-${pkgver}"
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/python-wsgidav/LICENSE"
+ install -Dm644 "${srcdir}/LICENSE-v${pkgver}" "${pkgdir}/usr/share/licenses/python-wsgidav/LICENSE"
install -Dm644 "${srcdir}/uwsgi.py" "${pkgdir}/usr/share/python-wsgidav/uwsgi.py"
install -Dm644 "${srcdir}/uwsgi.ini" "${pkgdir}/usr/share/python-wsgidav/uwsgi.ini"
install -Dm644 "${srcdir}/config.example.json" "${pkgdir}/usr/share/python-wsgidav/config.example.json"
+ install -Dm644 "${srcdir}/config.example.json5" "${pkgdir}/usr/share/python-wsgidav/config.example.json5"
}
diff --git a/config.example.json b/config.example.json
index 5836ec6615ac..7ef227870975 100644
--- a/config.example.json
+++ b/config.example.json
@@ -1,11 +1,11 @@
{
"host": "files.example.com",
"mount_path": "/webdav",
- "provider_mapping": {"/myfiles": "/path/to/files"},
+ "provider_mapping": { "/myfiles": "/path/to/files" },
"simple_dc": {
"user_mapping": {
"/myfiles": {
- "myuser": {"password": "mypassword", "description": "", "roles": []}
+ "myuser": { "password": "mypassword", "description": "", "roles": [] }
}
}
},
diff --git a/config.example.json5 b/config.example.json5
new file mode 100644
index 000000000000..9242b8f914b9
--- /dev/null
+++ b/config.example.json5
@@ -0,0 +1,13 @@
+{
+ "host": "files.example.com",
+ "mount_path": "/webdav",
+ "provider_mapping": { "/myfiles": "/path/to/files" },
+ "simple_dc": {
+ "user_mapping": {
+ "/myfiles": {
+ "myuser": { "password": "mypassword", "description": "", "roles": [] },
+ },
+ },
+ },
+ "verbose": 1,
+}